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Introduction

This document provides basic instructions and 
recommendations for running the steady-state and 
transient versions of the 2016 Dane County ground-

water flow model using the Groundwater Vistas (Vistas) 
user interface. The steady-state model was calibrated to 
reflect average groundwater conditions between 2006 
and 2010. There are also two transient models—one is an 
example of a new well pumping under average conditions, 
and the second is calibrated to the drought period during 
June and July 2012. This model has been significantly 
improved since release of the 1996 model (Krohelski and 
others, 2000).

This publication is intended to assist technical users in 
running the model; for a comprehensive discussion about 
the development, construction, and calibration of the 
model, refer to the modeling report, The 2016 Groundwater 
Flow Model for Dane County, Wisconsin (Parsen and others, 
2016). 

The 2016 model can be run directly using native 
MODFLOW files, but most users will need a graphical 
interface, such as Groundwater Vistas, to view and edit 
model input and results. A version of the Groundwater 
Vistas model including all necessary files, as well as the 
native MODFLOW files, are available for download from 
the UW-Box folder dedicated to the Dane County model: 
https://uwmadison.box.com/dane-groundwater-model

This model was last modified using version 6.74 build 37 
of Vistas, so users should update to at least this version of 
Vistas before attempting to run the model.

NOTE: This guide assumes 
the user has a basic knowl-
edge of MODFLOW and 
Groundwater Vistas, and is 
not intended to replace user 
manuals for these programs. 
Refer to the list of additional 
resources for links to recom-
mended guides.

Additional resources
Groundwater Vistas (software)

The Help menu at the top of the screen offers 
extensive documentation and assistance 
troubleshooting problems.

Groundwater Vistas: Online user manual 
groundwatermodels.com/ 
Groundwater_Vistas.php 

Environmental Simulations Incorporated  
(developer of Groundwater Vistas) 
groundwatermodels.com

Technical support, webinars, and seminars 
for Groundwater Vistas.

MODFLOW: Online guide (USGS) 
water.usgs.gov/nrp/gwsoftware/ 
modflow2000/MFDOC

MODFLOW: Report (USGS) 
pubs.usgs.gov/tm/2005/tm6A16

https://uwmadison.box.com/dane-groundwater-model
http://www.groundwatermodels.com
http://water.usgs.gov/nrp/gwsoftware/modflow2000/MFDOC/
http://water.usgs.gov/nrp/gwsoftware/modflow2000/MFDOC/
http://pubs.usgs.gov/tm/2005/tm6A16/index.html
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Background information and settings

Before you begin, you may find it helpful to familiarize 
yourself with the model layers used, as well as key 
settings and a brief comparison of the two condi-

tions—steady state and transient—for which the model 
was calibrated.

Model layers
The new model uses a 12-layer system. Figure 1 identifies 
each layer and shows how they relate to the previous 
model’s layers as well as to the general bedrock geology of 

Dane County. The thicknesses and vertical extents of the 
new model layers are not necessarily coincident with the 
stratigraphic unit formations. 

Note that all model layers are treated as continuous 
across the model domain. In places where specific layers 
are absent, they are referred to as “pinchout” layers. The 
thicknesses of pinchout layers are set to 0.2 ft and made 
effectively transparent by assigning hydraulic conductivity 
values (Kv, Kx, and Ky) as equal to those of the first underly-
ing layer that does not pinch out. 

GENERAL BEDROCK STRATIGRAPHY GROUNDWATER FLOW MODEL

Age Stratigraphic name Model layers, names

TypeEra Period Group Formation 1996 model 2016 model

1 Sand and gravel

1

Unlithified I  
(fine-grained 
lacustrine deposits 
within the glacial 
Lake Yahara area)

aquifers

2
Unlithified II  
(till and meltwater 
stream deposits)

Pa
le

oz
oi

c

Ordovician

Maquoketa

2 Upper bedrock

3 Upper bedrock

Sinnipee

Galena

Decorah

Platteville

Ancell
Glenwood

St. Peter

Prairie du Chien

Cambrian

Trempealeau
Jordan 4 Jordan

St. Lawrence 5 St. Lawrence

Tunnel City Lone Rock, 
Mazomanie

6 Tunnel City—Upper

7 Tunnel City—Mid 
(fracture layer)

8 Tunnel City—Lower

Elk Mound

Wonewoc
9 Wonewoc—Upper

10 Wonewoc—Lower 
(fracture layer)

Eau Claire 3 Eau Claire 11 Eau Claire aquitard

Mount Simon 4 Mount Simon 12 Mount Simon aquifer

Precambrian Various unnamed units No-flow boundary

General bedrock stratigraphy adapted from Preliminary Bedrock Geology of Dane County, Wisconsin  
(Wisconsin Geological and Natural History Survey Open-File Report 2013-01).Figure 1. Bedrock stratigraphy and corresponding layers in the 1996 and 2016 groundwater models.  

(General bedrock stratigraphy was adapted from Preliminary Bedrock Geology of Dane County, Wisconsin:  
Wisconsin Geological and Natural History Survey Open-File Report 2013-01.)
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Model units, orientation,  
and GIS options
The model units are in feet and the time unit is days, 
which can be viewed here: Model > MODFLOW > Package 
Options, under the Basic tab. The real-world spatial units 
or map units (called “site coordinates” in Vistas) are in 
meters. This is important to remember when importing 
or exporting basemaps, well locations, or other features 
into or out of Vistas. The coordinates of imported features 
need to be in meters and coordinates of exported fea-
tures will be output in meters if the output is a shapefile. 
By contrast, if you are exporting ASCII grid files, such as 
a Surfer grid, these will be output in model coordinates 
(feet), which do not reflect the selected offset coordinate 
system. Attributes, like hydraulic conductivity or recharge, 
are reported in ft/day.

To orient the model properly with map files when export-
ing to GIS, the GIS options (under Edit > GIS Options…) 
should be set as shown in the screenshot.

The projection file is a GIS projection file (.prj) that specifies 
the correct GIS coordinates. You can leave this blank if you 
prefer to project the output shapefiles later or browse for a 
desired .prj file that you are currently using. We commonly 
use NAD 83 HARN Wisconsin TM in meters.

There is no grid rotation.

Within Dane County, which represents the near-field of 
the model domain, each cell size is 360 x 360 ft. Beyond 
Dane County, in the far-field of the model domain, grid cell 
sizes increase using a multiplier of 1.4. North and south 
of Dane County, this multiplier is applied to the y-dimen-
sion (row height) resulting in taller model cells, while east 
and west of Dane County, the multiplier is applied to the 

x-dimension (column width) resulting in wider cells. Cells 
to the northwest, northeast, southeast, and southwest 
increase in size in both the x and y directions.

Basic information about the model grid (number of rows, 
columns, layers, cells), grid spacings, and model coordi-
nates are summarized in the Model Summary window 
(Model > Model Information).

Steady-state and transient models
The Dane County groundwater model was calibrated both 
to steady-state and transient conditions. The steady-state 
model represents average equilibrium conditions where 
heads or fluxes do not change over time, while the tran-
sient model is capable of accounting for changes in head 
or fluxes over time. The steady-state model was developed 
first and is generally calibrated to average hydrogeologic 
conditions (such as pumping rates, recharge rates) as they 
existed between 2006 and 2010. The steady-state model 
was calibrated by varying recharge, hydraulic conductivity, 
and stream and lakebed properties. It also served as the 
starting point for transient calibration, which simulated 
the drought conditions during June and July 2012. During 
transient calibration, recharge was assumed to be zero 
and only storage parameters (specific storage and specific 
yield) and lake surface evaporation were varied to match 
observed data.

While some sections of this User’s Guide are relevant to 
both model conditions, the guide generally refers to the 
steady-state version. For information that is exclusively 
about the transient model, see the section titled Transient 
Simulations.

Orient the model with map files when exporting to GIS.
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Technical setup
Newton Solver
This model uses the USGS Newton formulation of 
MODFLOW-2005 called MODFLOW-NWT. This is a sophis-
ticated solver that is intended for problems involving 
drying and rewetting of cells, and is essential for the 
complex 12-layer Dane County model. In Vistas, this 
solver is included in Model > MODFLOW2005 > Packages. 
While MODFLOW-NWT is already selected in the 2016 
Dane County model, it is important to understand where 
to activate the Newton Solver. To implement it in Vistas, 
the checkbox next to “Use Upstream Weighting Package 
(UPW) and Newton Solver (NWT) instead of LPF package” 
must be checked in the Model > MODFLOW2005 > 
Packages window. 

The solver parameters are set under the Model > 
MODFLOW2005 > OPTIONS > NWT General tab. However, 
these options have been optimized for best model per-
formance and should not be changed. Note also that the 
solver unit number, which MODFLOW uses to keep track 
of input and output files, is still set under the Model > 
MODFLOW > Packages tab even though the solver method 
(PCG2, etc) specified on that tab is ignored.  

Directories
Be sure to properly set up the working directory prior 
to running the model on a new machine (Model > Path 
to Models). The working directory is the folder where all 
output files will be stored. The executable files are also 
set up using the Paths to Models box; this is described 
in a separate section (Running the model). You may also 
choose to change the root file name for the output files 
under Model > MODFLOW > Packages.

Map files
The model is loaded with three map files already in Vistas 
.map format. These files must be kept in a separate direc-
tory and loaded when Vistas starts up. 

The three preloaded maps files:

Dnbndw.map	 county boundary

Dnhydrow.map	 surface water features

Dane_roads_2012.map	 roads and highways,  
current as of 2012

To load additional maps, go to File > Map and select the 
format of the map you want to import. This allows you to 
browse for a map and add it to Vistas.  All maps that are 
loaded are viewable in Plot > Map Overlays…. From this 
window you can select to draw, not draw, or delete indi-
vidual maps. You can also change the thickness of the map 
lines. The display of maps can also be controlled by going 
to Plot > What to Display… and selecting or unselecting 
the box Display Base Maps. For a map to be viewable it 
must be set to Draw in the Plot > Map Overlays window.

TIP: The roads map is quite 
detailed and can be slow to 
load if you are looking at the 
whole county. We generally 
turn it off when zoomed out.

Check box to activate Newton Solver
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Running the model

There are two common ways of running the Dane 
County groundwater model. The first is using the 
native executable file (MODFLOW-NWT.exe) from 

USGS. This method is faster, but requires some initial setup 
and does not display onscreen results of how the model is 
running. In general, we recommend this method as it uses 
the “official” and most up-to-date USGS solver. The second 
method is using the MFNWTWIN32.dll executable supplied 
with Vistas. This option takes longer to run but is easy to 
set up because it is the default method in Vistas. The two 
methods are described in more detail in the following 
sections. 

By running the USGS  
executable file in Vistas
The first way to run the model is in Vistas using the execut-
able file from USGS (MODFLOW-NWT.exe or MODFLOW-
NWT_64.exe). This method requires that you change two 
simple settings in Vistas and understand a bit more about 
how the executable file reads and writes all the other files 
using the name (.nam) file. It displays only limited feed-
back during the run. However, you can check on the prog-
ress of a model run by opening the list (.lst) file. For more 
details, see instructions under “Monitoring a Transient Run.”

To run the model in this way you first need to download 
the .exe file from USGS and save to your computer. 

In Vistas, create datasets by clicking on Model > 
MODFLOW > Create datasets. This will create a number of 
files including a name (.nam) file which are saved in the 
working directory (see “Directories”). The name file is a list 
of all the input and output files needed to run the model. 
Open the directory to confirm the name file is there. 
Then, in Model > Paths to Models (see screenshot), set 
the MODFLOWwin32 Option to “Do Not Use,” and set the 
MODFLOW path to wherever the MODFLOW-NWT_64.exe 
file is saved. In the Command Line box, enter the name file. 

NOTE: In parts of the county, particularly in the 
unglaciated Driftless Area, large regions of model 
layers 1–3 are above the water table and thus 
unsaturated. This will produce the following warn-
ing: “…these cells will start out dry…” when the 
model files are written; the warning can be ignored.

TIP: We recommend 
using the latest version 
of the USGS NWT solver 
(MODFLOW-NWT). As of 
January 2016, this was 
version 1.0.9. The file is 
available from the USGS: 
water.usgs.gov/ogw/
modflow-nwt

Settings used to run the USGS executable file

http://water.usgs.gov/ogw/modflow-nwt/
http://water.usgs.gov/ogw/modflow-nwt/
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Once this has been set up, you can run the model (Model 
> MODFLOW > Run model). A DOS window will pop up to 
show you the model has started running (see screenshot). 

Note that the following message will pop up in Vistas 
immediately: “MODFLOWwin32 is finished! Process 
the results?” This message can be misleading because 

the model is running using the executable file, not 
MODFLOWwin32. You can either wait for the model to 
run before clicking “yes”, or you can click “no” to make the 
box disappear. This won’t interrupt the run and will let you 
perform other tasks on the computer while the model runs 
in the background.   

By running the  
.dll file in Vistas
This method is easiest to implement, 
as it is the default method in Vistas. It 
is visually more satisfying because it 
yields a continuous readout of what the 
model is doing and the error criteria 
as they change. This comes at a cost 
though, as the computer must use 
overhead to write to the screen, so 
running the steady-state model takes 
a few minutes longer than the other 
method, and can essentially lock up 
your computer making multitasking 
very slow. In addition, it does not use 
the official USGS solver so may give 
slightly different results than or be less 
computationally stable than the USGS 
solver.

To use the Vistas .dll file, go to Model > 
Paths to Models (see screenshot) and 
set the MODFLOWwin32 option to “Run-Execute.” Next, set 
the Path and Code Name to the “MFNWTWIN32.dll”. You 
will need to browse to find the .dll file in the folder where 
you installed Vistas on your computer. You do not need to 
enter anything in the Command Line. 

From here you can create datasets and run the model 
through the Model > MODFLOW menu.

DOS window showing the model running

Settings used to run the .dll file in Vistas
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Viewing model results
After running the model, you will select what results to 
import (see screenshot). Check the box next to the files 
you wish to import. If you are looking at fluxes, you must 
import the cell-by-cell flow file.

Run time
Run time depends on the processing speed of the com-
puter used, other processes running on the computer, 
and the complexity of the MODFLOW problem. The 
steady-state Dane County model generally runs in under 
5 minutes on a typical 64-bit machine. Longer run times 
will occur if model stresses are substantially changed by 
adding or removing wells.

Model output
Running the model produces a number of ascii output files 
that contain useful information, in addition to the binary 
files (.hds, .ddn, .cbb) that can be imported into Vistas. 

Output files: 

File type Extension Details

List .lst Standard MODFLOW output 
file with the model budget 
(including lake budgets) at the 
bottom.

BYND .byn Reports node-by-node flows 
in or out of each multi-node 
well, along with the calculated 
head inside the well, and a 
seepage elevation if any of the 
nodes go dry. Important for 
checking to see that the wells 
are operating as expected and 
for evaluating cross-formation 
flow through well bores.

QSUM .qsm Also reports well-by-well flows 
but totals the flow for each 
well and gives the average 
head for the well.

Additional output files can be specified by editing the 
output control file. To edit the output control file, go to 
Model > MODFLOW > Package Options…, on the “Output 
Control” tab, check the box next to “Use Custom Output 
Control”, and specify the “Number of Custom Steps”. By 
doing this, the default settings are deactivated and you 
will need to set up the output control under Model > 
MODFLOW > Custom Output Control.... 

Select results to import for viewing
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Viewing and editing model features
Lakes (LAK3 package)
The model simulates the major Dane County lakes (Yahara 
chain plus Fish and Crystal Lakes) using the MODFLOW 
LAK3 package. This allows the stage, volume, and dis-
charge (for lakes with outlets) to fluctuate during model 
runs, and also allows the lakes to exchange water with the 
groundwater system and with routed streams (described 
below in the “Streamflow Routing” section). In the model 
input and output, the lakes are numbered as follows: 

Model 
lake num. Lake

1 Mendota

2 Wingra

3 Monona

4 Waubesa

5 Kegonsa

6 Fish

7 Crystal

A summary of simulated lake parameters, including a 
water budget for each lake and lake stage, is printed at 
the bottom of the .lst output file just above the overall 
model budget. If the Boundary Condition (BC) button has 
been activated, and cell-by-cell flow has been imported 
into Vistas, you can hover the cursor over each lake cell to 
see the simulated stage and flux (F). The data for the node 
appears in the lower left corner of the screen. Negative flux 
values indicate flow into the lake (from groundwater); posi-
tive flux values indicate flow out of the lake (to ground-
water) in units of cubic feet per day. To see the actual flow 
rate at the inlet or outlet of a lake, hover the cursor over 
the SFR2 cell that is directly upstream (lake inlet) or down-
stream (lake outlet) from the lake. 

Streamflow routing (SFR2 package)
All major streams in Dane County are routed using the 
streamflow routing (SFR2) package in MODFLOW. The 
streams are dynamically connected to the lake system to 
allow groundwater exchange between the two. An import-
ant feature of the 
SFR2 package is that 
streams can lose water 
and even go dry if the 
groundwater head 
drops below the stream 
base and the head in 
the stream drops to the 
stream base.

Where continuous 
human-made dis-
charges to streams are known to occur (such as the Nine 
Springs sewage treatment plant discharge to Badfish 
Creek and Badger Mill Creek), average discharge flows 
are added to the streams at appropriate segments. These 
types of additional SFR2 flows can be manually modified 
in the Model > MODFLOW2000 > SFR2 Segment Data… 
window in the “flow” column. This may be important if 
you are interested in making pre-development model 
runs (remove all sewerage discharge flows) or performing 
other scenarios involving man-made changes to stream-
flow. This process can be rather tedious because you may 
need to scroll down through the segment data window to 
add, modify, or delete individual flow data. For a list of the 
segments corresponding to all wastewater treatment plant 
discharges, see appendix 2 in the Dane County model 
report. For more information on SFR2, see the section 
“Understanding Streamflow Reporting.”

NOTE: Routed streams are 
identified by numbered 
segments and reaches. 
The number and order 
of these reaches is very 
important and should not 
be changed.

NOTE: Altering the lake parameters may cause model instability. The 
lake package can respond only to parameters input into the model, such 
as precipitation, lakebed properties, and groundwater pumping. The Dane 
County lakes and the Yahara River system also respond to human-made 
changes (lock and dam settings) and hydraulic changes (weed growth, weed 
cutting, dredging, backwater effects) that are not directly simulated by the 
model. The model can be used to investigate these effects, but changing 
lake and stream parameters should be done with great care and with an 
understanding of what each parameter does.
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Wells (MNW2 package)
The model uses the MODFLOW 2000 Multi-Node Well 
(MNW2) package. This option allows borehole flow to 
occur between model layers connected by open boreholes 
even if the well is not being pumped. 

To view a well, the Analytic Element (AE) button must be 
selected and you need to be in a model layer correspond-
ing to the open, or uncased, interval of the desired well. 
Then, click on the well icon; when the Well Information 
window opens, select the Basic Data tab. You can see 
the Multi-Node Well option is checked next to “Use as 
Fracture Well (FWL4 or 5) or Multi-Node Well (MNW) or 
CLN (MF-USG)”.

When this option is active then additional parameters are 
entered on the Multi-Node Well Data tab. These ordinarily 
do not need to be changed but must be entered if adding 
a well to the model.

Adding a new well
To add a new well, you will need to activate the “Add Well” 
tool. To do this, zoom in to where you would like to add the 
well, click AE > Well and activate the tool. Then click the 
mouse button where you would like to insert the new well; 
a pop-up window will appear for you to add the necessary 
information about the new well. Be sure to click on each of 
the tabs and complete the information outlined below. 

Basic Data tab: Set the exact coordinates 
of the new well location (“X”, “Y”), the 
model layers corresponding to the open 
interval of the pumping well (“Top Layer of 
Screen”, “Bottom Layer of Screen”), and the 
“Steady-state Pumping Rate”. A negative 
pumping rate represents a withdrawal from 
the groundwater system, while a positive 
pumping rate represents an injection. 
Pumping rates must be entered in cubic 
feet per day so a unit conversion is typically 
necessary. In this tab you can also name the 
well. Check the box “Use as a Fracture Well 
(FWL4 or 5) or Multi-Node Well (MNW) or 
CLN (MF-USG)” to activate MNW2 function-
ality. Keep the default settings for all other 
fields.

NOTE: If pumping causes an indi-
vidual node to go dry when using 
the MNW2 package, the model will 
“turn off” pumping from that node. 
In other words, MODFLOW adjusts 
the well discharge rate to sustain 
pumping. This means that the final 
simulated pumping rate from an 
individual well might be less than 
what was specified in the well input 
file. There is no obvious warning 
when this occurs, but it can be easily 
seen in the .byn file (described in 
“Model Output”). Check this file to 
verify that the simulated pumping 
equals the desired pumping.

Adding a new well—Basic Data tab settings
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Fracture Well Data tab: All fields should 
be left as default.

Multi-Node Well Data tab: Set the 
“Friction Loss Coefficient (Skin or Rskin)” 
to “2”, “Well Loss Options (LOSSTYPE)” 
to “Skin Corrections”, and “Hydraulic 
Conductivity of Skin (Kskin)” to “10”, as 
shown below. Leave default settings for all 
other fields.

CLN Data tab: All fields should be left as 
default.

Editing an existing well
To edit an existing well, such as increasing 
the pumping rate, make the changes to 
the Basic Data tab. Refer to the “Adding 
a New Well” section for instructions on 
accessing the Basic Data tab.

Removing an existing well
To remove existing wells, they first need 
to be selected using Edit > Select By or 
Edit > Select All. Then press the delete 
key to remove the wells. You can confirm 
that wells were removed by checking the 
total number of wells listed on the model 
information window (Model > Model 
Information). If you are interested in 
deleting all wells, for example to simulate 
predevelopment conditions, you can 
simply select all wells (Edit > Select All > 
Well) and press delete.

Adding a new well—Fracture Well Data tab settings (no changes)

Adding a new well—Multi-Node Well Data tab settings

Adding a new well—CLN Data tab settings (no changes)
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Groundwater contribution to wells by layer  
(borehole flow)
A benefit of using the Multi-Node Well package is the 
ability to obtain a detailed record of the groundwater con-
tribution of each model layer to the overall groundwater 
withdrawal from a particular well. For example, a well with 
an open interval from layers 9 to 12, would withdraw water 
from each of the four layers at a different rate depending 
on the hydraulic properties of the aquifer in each layer the 
well intersects. This allows you to determine which model 
layers are producing more or less water and may guide 
decisions regarding the optimum open interval of a well. 
The MNW package may also be used to determine passive 
groundwater flow between layers in unpumped wells. 
This is particularly applicable for multi-aquifer wells whose 
open interval spans the Eau Claire aquitard, allowing 
groundwater to directly move from the overlying aquifer 
system into the Mount Simon aquifer.

To look up the mass balance of groundwater flow within a 
well, see the .wel file created for each model run. This file 
includes the flow for each well by layer.

Springs
The model simulates major Dane County springs (Pheasant 
Branch, Culver, Donald, etc.) using the Streamflow Routing 
package and by inserting high-hydraulic conductivity 
nodes at and below the appropriate spring locations. Flow 
from springs can be determined by onscreen query as 
described in “Understanding Streamflow Reporting.”

For a complete listing of model nodes that correspond to 
springs, refer to appendix 7B of the Dane County model 
report.

Recharge
Groundwater recharge in Dane County varies spatially 
across the landscape. Initial values of recharge were taken 
from a soil-water-balance (SWB) model developed by Hart 
and others (2012), and were adjusted regionally during 
model calibration. In this model, evapotranspiration is 
accounted for in the recharge values so that recharge rep-
resents the water that actually reaches the water table.

Recharge can be viewed by selecting Props > Recharge. 
The lower-left corner displays recharge in units of feet/day. 
Ponding depth is also shown; the model allows ponding 
up to this depth if the water table rises above land surface.

Users may wish to modify the recharge to simulate the 
steady-state conditions following land development or a 
change in climate. However, recharge should be modified 
with caution due to the complexity of the initial value 
distribution and the unknown consequences of future 
climate change (such as increased pumping during a 
drought).

To directly edit recharge in a specific cell or area, select 
Props > Set Value or Zone. The screenshot below shows 
how to set recharge at a single cell.

Model-wide changes to recharge may be simulated using 
multipliers. To do so, first confirm that Recharge is selected 
from the Props menu. Then, select Props > Property values 
> Recharge Multipliers. Enter the desired multiplier. 

Setting recharge for individual cells

Use multipliers to make global changes to recharge
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Understanding streamflow 
reporting (SFR2 package)
The streamflow routing (SFR2) package is a powerful 
modeling package that calculates the amount of water 
entering (from groundwater) and leaving (to ground-
water) each stream cell, as well as the cumulative flow rate 
in the stream at each stream cell. This section describes 
how to use SFR2 output to determine the mass balance of 
water entering and leaving each stream cell in the model. 
Understanding how groundwater and surface water inter-
act is an important component of many water resource 
evaluations. 

Following a run, once model results (including the cell-
by-cell flow .cbb file) have been imported, Vistas can be 
queried to show the simulated streamflow at any stream 
point. To do this, you must turn on the Stream Boundary 
Condition (BCs > Stream) or specify Stream in the drop-
down Boundary Condition box. Next, hover the cursor over 
any stream node (you must be in the model layer contain-
ing the SFR2 stream node, typically layer 1 or 2). The lower 
left corner of the screen will report the following informa-
tion about the node:

■■ s (segment) = a long segment of the stream (we’d 
normally call this a reach)

■■ r (reach) = an individual node along that segment

■■ H (head) = the hydraulic head in the stream

■■ F (flux) = flux into or out of that particular reach 
(node). Note that a negative value means flux out of the 
groundwater system and into the stream node; a positive 
value means flux into the groundwater system and out 
of the stream node. 

■■ Flow = accumulated baseflow in the stream. Flow 
equals the sum of all individual node fluxes from the 
first stream node (upstream) up to and including the 
node of interest. This number should always be positive 
or zero if the stream is dry.

Based on the screenshot below, the streamflow report 
should be understood as follows:

■■ s (segment) = 715

■■ r (reach) = 4

■■ H (head) = 851.63 feet above mean sea level

■■ F (flux) = 1.397 x 104 cubic feet per day (again, nega-
tive flux means water is moving out of the groundwater 
system and into the stream)

■■ Flow = 3.642x105 cubic feet per day (accumulated 
baseflow of stream up to, and including this node)

To better understand this, go to the most upstream 
segment of any stream and hover the cursor over that 
node. For this node, flux (F) should equal the negative of 
flow as reported by Vistas. Some headwater SFR2 nodes 
may report flux and flow equal to zero, indicating that 
they are simulated as dry. In contrast, SFR2 segments that 
receive additional contributions of water from wastewater 
treatment plant discharges, would record a jump in total 
cumulative flow. For more discussion about wastewa-
ter treatment plant discharges refer to the “Streamflow 
Routing” section.

Sample streamflow report
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To view all SFR2 cells at once go to the Boundary 
Conditions (BCs) drop-down window (select Streams), 
press Options… and check the box “Display All BCs When 
Viewing Layer 1”. This will allow you to view all SFR2 cells 
as long as you are in model layer 1. As you drop down to 
lower layers, only the SFR2 cells present in that layer will be 
visible. To see which SFR2 cells are present only in layer 1, 
uncheck the box (see screenshot).

To manipulate and study streamflow results, it is best 
to export the streamflow data as a shapefile from the 
Boundary Conditions (BCs) drop-down window (BCs > 
Export > Shapefile) and work with the data in GIS. When 
exporting a shapefile of the streamflow results, name the 
shapefile accordingly and select the shape type. Polygon 
(model cells) will export polygons representing the model 
cells while the type Point (nodes) will export a point 
feature class of nodes located at the center of each stream 
cell. Either way the same streamflow attributes (s, r, H, F, 
and flow) will be exported for all stream cells.

NOTE: We have developed an 
ArcGIS macro for easily compil-
ing streamflow information and 
comparing one run to another. This 
macro, the ArcMap SFR2 Baseflow 
Comparison macro, is documented 
at the end of this guide.

Uncheck box to view SFR2 cells present in layer 1 only
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Particle tracking using MODPATH

Particle tracking is a powerful way to help visualize 
the direction of groundwater flow and evaluate the 
impact of new or existing wells, simulate flow away 

from a landfill, or towards a subdivision. Particles can be 
simulated in both forward and reverse particle tracking 
mode, allowing the user to investigate groundwater flow 
both up-gradient and down-gradient from a specific 
feature of interest. This chapter provides a basic overview 
for how to perform particle tracking using MODPATH in 
Groundwater Vistas.

Currently the model is compatible with MODPATH 
version 5 (which is included with Vistas). Use the 
MP5WIN32.dll executable in Model > Paths to models.

Add particles to your model by going to the Analytic 
Element (AE) drop-down pane (AE > Particle) and selecting 
an appropriate shape for inserting particles. Particles can 
be inserted as single particles, lines, circles, window or 
digitized polygon features. Circles of particles work best for 
delineating capture zones of wells, while lines, windows 
and digitized shapes of particles work well for delineating 
flow paths to or from larger features, such as lakes and 
streams. 

NOTE: MODPATH v.5 will crash if the program 
encounters dry cells. To avoid this bug, before running 
MODFLOW, go to Model > MODFLOW2005 > Options, 
select the LPF Options tab, and put a check in the box next 
to “Set Head to HDRY in cells with small saturated thickness 
(IPHDRY)” (see screenshot).

TIP: If you plan to compare 
different model runs to calculate 
changes in drawdown, be aware 
that you won’t be able to use these 
heads from MODFLOW as starting 
heads because many of the cells 
will start out dry. To get around 
this, see the section “Calculating 
Drawdown”.

Check box to keep dry cells from causing MODPATH to crash
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The following example demonstrates how to 
perform a capture zone (area of contribution) 
analysis for a well by delineating a 100-year 
time-of-travel area.

Start by setting up the particle options under 
Model > MODPATH > Particle Options…, 
setting the Direction of Tracking to “Reverse”, 
checking the box “Limit Particle Travel Time” 
and entering the “Max. Travel Time” in days 
(100 years x 365 days = 36,500 days). If you 
do not limit the particle travel time in this 
window, the particle traces will be infinite. We 
recommend leaving all the other check boxes 
and settings as shown in the screenshot.

If you are viewing particle traces in Vistas only 
(not exporting as a shapefile), you may wish 
to not select a maximum travel time since this 
allows you to view any desired particle travel 
time by adjusting the “Maximum time” in Plot 
> Particles > Options under the Display tab. 
A number of other particle display options 
are available in this window, including color 
coding particles based on model layer or 
adding arrows and time postings along the 
particle travel path.

Settings for particle tracking

Displayed maximum travel time can be adjusted here if 
viewing particle traces in Vistas only (not exporting)
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Once you have set the particle options in Model > MODPATH 
> Particle Options…, the next step is to insert circles of par-
ticles for the well of interest. Under the Analytic Element 
(AE) drop-down window, select AE > 
Particle > Circle. When you click on 
“Circle” the window will disappear and 
you can hover over the model space 
and click a spot where you would like to 
add a circle of particles. If you continue 
to hold down the button, you can adjust 
the diameter of the particle circle. When 
you release the mouse button, a pop-up 
window will appear next to the particle circle where you 
can enter the Circle Trace Information (see screenshot). 

The initial location and size of the particle circle is not 
critical since these settings can be adjusted in the pop-up 
window. You can also double click on the particle circle 
(just as you would with a well) to reopen the window. As 
for wells, to select a particle circle, the Analytic Element 
(AE) tab must be selected and you need to be in the same 
model layer containing the particles.

Place the particles as close as possible to the center of 
the model cell. To aid in this, we recommend making the 
model grid cells visible (go to Plot > What to Display, and 

check “Display Finite-Difference Grid”). 
While the well you may be interested 
in is not necessarily located in the 
exact center of the model cell (as in the 
screenshot below), the center of your 
particle circle needs to be in the center 
to correctly perform a particle trace for 
the well. This is because the numerical 
model solution is solved for the model 

node, which is located at the exact center of the model 
cell. One simple way to do this is to first make the diameter 
of your particle circle equal to the cell size (set the circle 
radius to 180 ft since the cell size equals 360 x 360 ft), and 
then manually adjust the Spatial Parameters (coordinates 
“X” and “Y”) by trial and error until the circle exactly fits 
in the middle of the model cell. Once the particle circle is 
centered, the radius can be changed back to 74.8 ft. The 
radius of the particle circle should be 74.8-ft based on the 

Click on a particle circle to open the Circle Trace Information box

TIP: Specify the layer for adding 
particles directly from the pop-up 
window. This is often easier than 
clicking down to each model layer 
and adding circles for a particular 
model cell.

NOTE: The effective radius 
for the near-field of the 
Dane County model is 
calculated as 360 ft (model 
grid interval) ÷ 4.81 = 74.8 ft.
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size of the model cells (360 x 360 ft) and the principles of 
converging flow near a pumped well node (Prickett and 
Lonnquist, 1971). 

When doing reverse particle tracking to delineate capture 
zones for wells, we recommend using three circles of 10 
particles in each open interval layer of the well. In other 
words, if the well is a multi-aquifer well which is open 
between model layers 9 and 12 you would place three 
circles of 10 particles in layers 9, 10, 11, and 12 (a total of 
12 circles and 120 particles). You will also need to specify 
the open interval of the well (“Top Layer” and “Bottom 
Layer”) and the “Number of Vertical Release Points” to “3”. 
For this example, set the top layer to 9 and the bottom 
layer to 12. Leave the remaining default settings as shown 
above.

If the particles are not visible after creating them, make 
sure that the checkbox “Display Particle Starting Locations” 
is selected in Plot > What to Display.

Now that you have created a particle circle, create 
MODPATH datasets (Model > MODPATH > Create Datasets) 
and run MODPATH (Model > MODPATH > Run MODPATH). 
Just as for running MODFLOW in Vistas, you can view the 
Error/Warning File by clicking “Yes” in the pop-up window. 
Once MODPATH is finished running, particles can be dis-
played by selecting the checkbox “Display Particle Traces” 
in Plot > What to Display.

To export particles, go to File > Export…, type in a file 
name, select the appropriate file type (such as a shapefile 
(.shp)), and save. If exporting as a .shp file, the next pop-up 
window will allow you to name the file and set the type of 
output to export (Result Type: Particle Traces). 

TIP: If working with exported particle traces in 
ArcMap, be sure to correct the location of the 
particles back to the real-world coordinates at the 
center of you well of interest. If not, your particles 
will be offset by the same distance you moved 
them in Vistas to center them in the middle of the 
model cell.

Export particles to shapefile
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Calculating drawdown (comparing scenarios)

Drawdown calculations are performed to compare 
one set of water levels to another, such as compar-
ing predevelopment water levels to 2010 condi-

tions, or evaluating the impact of adding or removing new 
wells. Regardless of the objective, it is important to follow 
these steps:

First, save and run a version of the model that reflects 
initial drawdown conditions. For example, if interested in 
determining drawdown in 2010 compared to predevel-
opment, then predevelopment drawdown (no wells or 
wastewater treatment plant discharges) represents initial 
conditions. If interested in determining drawdown under 
an alternative scenario (say, wells removed or wells added), 
then 2010 drawdown represents initial conditions. Refer 
to the “Wells” and “Streamflow Routing” sections for more 
information about changing these features in the model.

When the initial-conditions run is complete, open a version 
of the model that reflects the changed drawdown condi-
tion (for example, 2010, well(s) added, or well(s) removed). 
Next, go to Model > MODFLOW > Package Options > Initial 
Heads, set the Initial Head Location to “Read Heads Directly 
from binary head-save file”, and browse for the corre-
sponding File Name. Select the .hds file that corresponds 
to the initial drawdown condition created earlier. Same 
as for the initial-conditions version, the box “Set Head to 
HDRY in cells with small saturated thickness (IPHDRY)” 
needs to be unchecked before running the model. The 
drawdown comparison will only work if this HDRY option 
is unchecked for both the initial- and changed-condition 
runs.

Now create datasets, run the model, and import results 
for the changed-conditions version. Be sure to check the 
box to import the Drawdown File when importing results. 
Once results are imported, go to Plot > What to Display, 
check the box “Display Contours of”, and select Drawdown 
from the drop-down menu to display contours of draw-
down. To display a color flood of drawdown, check the box 
“Display Color Flood of” and select Drawdown from the 
drop-down menu.

TIP: Before running the initial-conditions version, 
be sure to uncheck the box “Set Head to HDRY 
in cells with small saturated thickness (IPHDRY)” 
under Model > MODFLOW2005 > Options > LPF 
Options. Running the initial-conditions version of 
the model will generate a heads (.hds) file which 
will serve as starting heads in the subsequent 
model run under changed conditions.
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Transient simulations

There are two Dane County transient models, the 
new well example and the calibration example. Both 
are described in additional detail in the modeling 

report. The new well example demonstrates the transient 
response of a new high-capacity well pumping over a 
30-day period, and is typical of the type of analysis com-
monly needed for new high-capacity wells. The simulation 
uses two stress periods (30 and 60 days), each with 10 time 
steps, for a total simulation time of 90 days. This example is 
set up to calculate streamflows at two model nodes using 
the MODFLOW GAGE package (see “Using GAGE Package 
for Streams or Lake Stage”).

The calibrated Dane County transient model simulates 
drought conditions during June and July 2012. The model 
is divided into four stress periods of 10 to 14 time steps 
each to represent periods of different pumping rates. Each 
time step is equivalent to one day, for a total simulation 
time of 49 days. Recharge is set to zero throughout the 
simulation period. 

Be aware that transient simulations require significant 
model setup, and might require run times lasting several 
hours. Model stability and convergence can be issues 
depending on the specific problem being investigated.

We have not had success running the transient model 
using just the datasets created by Groundwater Vistas, 
but have provided the modified files necessary to run the 
transient model. Transient simulations require some initial 
file setup (see “Technical Setup”) and must be run slightly 
differently than steady-state simulations (see “Running the 
Transient Model”). 

Best practices for  
successful transient runs
The following tips should help in setting up successful 
transient runs:

■■ Use initial heads and lake levels as near to the final 
solution as possible. This should not be an issue unless 
changes are made to the model.

■■ When editing model parameters, be sure to prop-
erly set up all transient data for each stress period. 
Failing to do this is a common mistake and will lead to 
model crashes. Properties with transient data include 
recharge, streamflow routing, lakes, boundary condi-
tions, and well pumping. See “Editing Transient Model 
Parameters” for details.

■■ Run Vistas using the native executable file and correct 
file settings. This includes the NWT package, lake 

bathymetry, and name (.nam) files as described in 
“Files Needed to Run the Transient Model.” 

■■ Avoid increasing the duration of time steps. The 
model lakes are particularly unstable for large time 
steps.

■■ If using the model to plot hydrographs, use the GAGE 
package to capture stream flow and other mass 
balance data rather than saving entire model mass 
balance at every location. (See “Using GAGE Package 
for Streams or Lake Stage” for more details.)

Technical setup
Initial heads
A transient run should begin with initial (starting) heads 
taken from a previous successfully converged steady-state 
or transient run. During the initial run the “Set Heads to 
HDRY in cells with small saturated thickness (IPHDRY)” box 
in Vistas under MODEL > MODFLOW2005 > OPTIONS must 
be UNCHECKED. Files built with this box checked are not 
suitable for starting heads, and models using such files for 
initial heads will probably not converge. Unfortunately this 
is the opposite of what is needed for using MODPATH (see 
“Particle Tracking Using MODPATH”). Setting initial heads 
is the same for transient and steady-state. Select Model 
> MODFLOW > Package Options > Initial Heads, set the 
Initial Head Location to “Read Heads Directly from binary 
head-save file”, and browse for the corresponding file 
name from the initial run.

Files needed for running the transient model
The transient model should be run using the native USGS 
executable (MODFLOW-NWT) as it is the “official” and most 
up-to-date USGS solver. This is the same executable file 
described for steady state in “Running the Model,” available 
for download on the USGS Groundwater Information page: 
water.usgs.gov/ogw/modflow-nwt/. This file is typically 
saved with other computer program files.

A number of files provided by WGNHS are also necessary 
to run the transient model. The following files should be 
placed in the working directory (as set in Model > Paths 
to models). Most of these files should not need to be 
changed. However, the name (.nam) file must be changed 
any time the Groundwater Vistas root file name is changed, 
as described in “Changing the Name File”. The lake files 
need not be changed unless lake properties are changed. 
See MODFLOW documentation for further descrip-
tion of the files and their format (water.usgs.gov/nrp/
gwsoftware/modflow2000/MFDOC/).

http://water.usgs.gov/ogw/modflow-nwt/
http://water.usgs.gov/nrp/gwsoftware/modflow2000/MFDOC/)
http://water.usgs.gov/nrp/gwsoftware/modflow2000/MFDOC/)
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See the above list for names of provided files needed to 
run the transient model.

Changing the name file
When you create datasets in Vistas, many files are gener-
ated, including a name (.nam) file. This file is a list of all the 
input and output files MODFLOW needs to run the model 
and so is critical for the run. However, we recommend 
using modified versions of some of 
the input/output files, which have 
been provided with the model 
(see “Files Needed for Running the 
Transient Model Outside of Vistas”). 
The name file must reference these 
modified input/output file names. 

Note: We have provided an example 
name file for each transient model. 
You may use this file for running the 
transient model unless you change 
the root file name. The root file name 
can be found in Model > MODFLOW 
> Packages (see screenshot).If you 
change the root file name, you will 
need to create your own edited 
name file. The name file is used later 
in “Running the Transient Model.”

Details File name

Bathymetry—gives stage/ 
volume relation for each lake

lak_bath1.txt (Mendota)

lak_bath2.txt (Wingra)

lak_bath3.txt (Monona)

lak_bath4.txt (Waubesa)

lak_bath5.txt (Kegonsa)

lak_bath6_Jul13.txt (Fish)

lak_bath7_Jul13.txt (Crystal)

Lake-bed leakance moddane5_BDLKNC.dat

Newton (NWT) solver package Dane9_rjh_4Mar14.nwt

Lake package Moddane7-5_rgn_mar14_trans.lak (calibrated model) 
Moddane7-5_rgn_mar14_trans_for_dd_test.lak (new well model)

Name file—specifies names  
of input and output files 

Dane_trans_final_USETHIS.nam (calibrated model) 
Transient_new_well_example_USETHIS.nam (new well model)

Provided files needed to run the transient model

Specify the root file name

NOTE: The name (.nam) file must be 
changed whenever the Groundwater 
Vistas root file name is changed. See 
“Changing the Name File” for details.



21

Wisconsin Geological and Natural History Survey

To change the name file, first create datasets in Vistas 
(Model > MODFLOW > Create Datasets). This will gener-
ate a name file similar to the one shown on the left in the 
screenshot below. Use a text editor such as Notepad to 
replace two lines of text with the appropriate edited files. 
Because these file entries are slightly different for the two 
transient models, a readme file with instructions has been 
included with each model.

The new name file should look similar to the screenshot 
(below right), except “Dane_trans_final” will be replaced by 
your root file name. The yellow highlight shows the edited 
lines.

Save the edited name file with a different name that you 
will remember. Every time you create datasets, the original 
name file will be rewritten. By using a different name, you 
are able to run various scenarios without changing the 
name file. However, remember to edit the name file when-
ever you change the root file name. 

The format of the name file is important; make sure the 
text editor does not change the format. Also, make sure 
the extension of the edited file is “.nam”. Some text editors 
will automatically change it to .txt or .dat; these will not 
work. 

Use a text editor to replace highlighted lines 
as shown; refer to the readme file included 
with the model for line entries

BEFORE AFTER
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Output control
Output control is used to determine how often data is 
saved. You should not have to modify this unless you wish 
to save data more or less frequently. In a transient run, 
the files generated by Vistas are quite large if the model 
saves data from every time step. For example, the transient 
calibration run has 49 time steps; saving all the data for 
every time step generates a cell-by-cell (.cbb) file of almost 
4 gigabytes. 

The model is currently set to save every two time steps 
(equivalent to two days). This is set in Model > MODFLOW 
> Package options > Output control tab (see screenshot).

Running the transient model
As with the steady-state model, the transient model can be 
run in several ways. The most important difference is that 
the modified name file (see “Changing the name file”) must 
be referenced.

By running the USGS executable file in Vistas 
The transient model may be run using the .exe method 
similar to how the steady-state would be run (see “Running 
the Model”). However, the edited name file must be spec-
ified (see “Changing the Name File”). In Models > Paths to 
models, enter the edited name file that you have saved 
in the command line. It is not case-sensitive. Your screen 
should look like the screenshot shown below.

Now you can run the model as you would for the steady-
state. See “Monitoring a Transient Run” for details on 
viewing model progress. 

Set time steps 

Running the USGS executable file in Vistas—specify the name file 
in the command line 
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By clicking on the executable (.exe) file
You may also run the model directly using the USGS 
MODFLOW executable file. This method allows the user 
to run the model without Vistas. Save the executable file 
(MODFLOW-NWT_64.exe) in your working directory, then 
double click on it, and enter the modified name file in 
the DOS command line. The model will begin running as 
described in the previous section.

By using a Windows batch file (.bat)
A third way to start the model is by using a batch file. This 
method is handy if you are running a model repeatedly. 
To use this method, you need to prepare a Windows batch 
file by opening a text editor and saving with the extension 
“.bat”. 

Here is an example, called Runtransient.bat:

MODFLOW-NWT_64.exe Dane_trans_final_USETHIS.nam

MODFLOW-NWT_64.exe Dane_trans_new well_USETHIS.
nam 

In this case, the name files refer to two different models 
to be run. Assuming the name files have been set up 
correctly, this batch file will run two models, one after the 
other. To run the model this way, double-click on the batch 
file name. This will execute the model and add the name 
file automatically, saving some typing. This also allows you 
to run several models in a row while you are away from 
your computer.

Monitoring a transient run
The DOS window will close when the model either finishes 
successfully or crashes. If it closes quickly (within a minute 
or so) there is likely an input problem. Successful transient 
runs might take as long as 1–2 hours depending on the 
simulation. To abort a run, press control-C in the DOS 
command line.

Because of these long run times, and because there is 
little screen feedback from the model, you might wonder 
whether it is actually running. 

There are three ways to track the progress of the run:

1.	 Look at the stress period and time step numbers in 
the DOS window. The numbers should gradually 
increase, changing every few minutes.

2.	 Look at the size of the list (.lst) file; it should gradually 
increase while the model is running.

3.	 Use Windows Explorer (or another file viewer) to open 
the .lst file, then scroll to the bottom to see what the 
model is doing. Opening this file will not interrupt 
the model run, but you will need to refresh (close and 
reopen) the file to track ongoing progress. Refreshing 
the file is particularly important if the model is taking 
a long time between time steps. If the model is not 
converging during the time steps, you can determine 
this by checking to see where the model is slowing 
down, such as near a model cell with a problematic 
well or stream section. If you spot this behavior, there 
is usually no point in continuing; it’s best to abort the 
run (control-C) and fix the problem. For help diagnos-
ing problems, see “Additional Resources”.

Sometimes the model will crash, and might list some 
errors. Again, looking in the .lst file is a good way to track 
down errors. Often crashes are due to errors or omissions 
in the name file. 
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Looking at transient output
Transient output files (heads, drawdowns, mass balance) 
can be imported into Groundwater Vistas similar to steady-
state runs, with the difference that you must specify the 
stress period and time step desired for viewing. Be aware 
that import might be slow because the output files can 
be very large, and Vistas has to sort through the large files 
to load the correct time step. This model has four stress 
periods with up to 14 time steps (days) each. You can 
choose the time step to display using the browse function 
under “import model results” and highlighting the time 
desired.

Vistas also has a handy feature under the “plot” menu that 
lets you switch between time steps (see screenshot at 
right).

Note that changing the stress period on the left sidebar 
only changes the displayed input values, not results. 

Choose the time step using the browse function 

A handy shortcut for switching 
between time steps

Changing the stress period in 
the sidebar changes displayed 

input values only, not results
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Plotting hydrographs
Using Vistas targets or monitoring wells for head
For transient runs, users will probably want to generate 
hydrograph plots of drawdown, water levels, or stream 
flow at specific locations. For monitoring head, this may 
be done by adding a target or monitoring well under the 
Analytic Element window prior to running the model (AE 
> Target or AE > Well). A target is typically a location where 
head or flux has been measured, and can be compared 
graphically to model results. Enter transient data by 
unchecking “Target is Steady-State” and clicking on the 
“Transient Data” button (see screenshot). You may also 
import data using the “Import” button.

Enter transient data by unchecking “Target is 
Steady State” box, then clicking the Transient 
Data button

Transient data entry area
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After loading the model results you can click on a target 
to see and/or export a hydrograph. To do this, first click 
on the target; this brings up the target menu. Then click 
on “Graph” to bring up the hydrograph (see screenshot 
below). Right-click on the graph to see export options.

Alternatively, you can add a well to monitor head (AE > 
Well). Check “Monitor Head/Concentration vs. Time” (see 
screenshot). Once you have run the model, view results 
using Plot > Hydrograph > Monitoring Well.

Monitor head by checking highlighted box

Click on a target to view its hydrograph;  
right-click on the graph to export
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Using GAGE package for streams or lake stage
We recommend using the GAGE package when plotting 
transient hydrographs of flows or lake stages. For hydro-
graphs, all the mass-balance data must be saved for every 
time step. Saving such data for all locations and time steps 
will generate enormous cell-by-cell (.cbb) files. To avoid 
this problem, the GAGE package will save the 
head or flow data only at specified stream 
or lake nodes. An example of this is included 
with the new well transient model.

A gage file may have the extension “.gag” 
or “.dat”. The screenshot at right shows the 
content and formatting of a typical gage file.

To use the GAGE package you must add the gage file and 
the specified output files to the MODFLOW name (.nam) 
file. The word “GAGE” must appear in the name file. Here is 
an example of the name file using the gage file above:

Explanation of highlighted text in the screenshot:

GAGE 67: References gage file (gagefile.dat) from the 
previous screenshot. “67” is a unit number not being used 
elsewhere. “GAGE” must be written out.

Data 51–53: Specifies the name of the output file for each 
gage and unit number (51–53) referenced in the gage file.

The screenshot below shows the partial contents of one of 
the gage output files. You can use another program (such 
as Grapher or Excel) to plot the hydrographs.

TIP: We find it easier to prepare the gage 
file using a text editor rather than Vistas. 

Before setting up the file, read the MODFLOW 
documentation on the GAGE package:  
water.usgs.gov/nrp/gwsoftware/ 
modflow2000/MFDOC/gage.htm. 

Number of gages

Gage locations 
(one line each)

segment reach output  
unit #

output  
flag

[

SAMPLE GAGE FILE  
(see MODFLOW documentation for details)

Partial contents of a gage output file

Add gage file and output file names to the 
MODFLOW name file

http://water.usgs.gov/nrp/gwsoftware/modflow2000/MFDOC/gage.htm
http://water.usgs.gov/nrp/gwsoftware/modflow2000/MFDOC/gage.htm


28

The 2016 Groundwater Flow Model for Dane County, Wisconsin—User’s Manual

Editing transient model parameters
Transient model properties must be set up for all stress 
periods. Properties with transient data include recharge, 
streamflow routing, lakes, boundary conditions, and 
well pumping. Basic changes to properties is discussed 
in “Viewing and Editing Model Features.” This section 
describes how to apply these changes to multiple stress 
periods. Note that boundary conditions cannot be 
changed within a stress period.

Changing recharge and boundary 
conditions
Users are cautioned that any changes to 
recharge in the transient model must be 
applied to all stress periods. Change the 
“stress period” box on the left side of the 
Vistas screen to view and edit the recharge 
for different stress periods. 

Likewise, boundary conditions need to be 
specified for each stress period. Just chang-
ing a boundary condition in the first stress 
period will not work. After any change you 
need to copy the change to all stress periods 
using the Vistas procedure: BCs >  Modify > 
Copy stress period and then putting in the 
range of stress periods you wish to copy to. 
The same technique applies to streams and 
lakes.

Changing well pumping
To edit transient pumping rates, click on the well and make 
sure the “Pumping Rate is Steady-state” box is unchecked. 
Click on the Transient Data button to enter transient 
pumping rates (see screenshot).

In the example shown below, the well is pumped at a 
different rate for each of the four stress periods.

To edit transient pumping rates, uncheck the “Pumping Rate 
is Steady-state” box, then click the Transient Data button

Example data for a well pumped at different rates for each of four stress periods



29

Wisconsin Geological and Natural History Survey

ArcMap SFR2 baseflow comparison macro

We’ve created a macro that runs in ArcGIS to calcu-
late streamflow changes at various sites through-
out the model. This section describes the macro 

and how to use it.

What the macro does
This ArcMap macro helps evaluate changes in streamflow 
between different model runs for any set of locations 
along the Streamflow Routing (SFR2) network. This is par-
ticularly useful when determining cumulative streamflow 
(baseflow contribution) at multiple stream locations across 
Dane County.

Installing the macro
From any current session of ArcMap, open the ArcToolbox, 
right click on the ArcToolbox icon in the upper left hand 
corner of the pop-up window, and select Add Toolbox. 
Next, select the Flux Calculations.tbx file from the ArcGIS 

folder included with the model files and press Open. This 
will add the macro to the ArcToolbox for the open ArcMap 
session; you’ll need to reinstall the macro each time you 
start a new ArcMap session.

Files needed to run the macro
To run the macro, you’ll need to export two shapefiles from 
Vistas—the initial SFR2 flux conditions (for example, 2010 
steady-state) and the changed SFR2 flux conditions (such 
as wells added). You’ll also need a shapefile containing 
the point locations where you are interested in extracting 
stream fluxes along the SFR2 network. 

Exporting SFR2 data from Groundwater Vistas
Under the tab BCs, highlight “Stream,” then click Export > 
Shapefile (see screenshot).

Export stream shapefiles
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Then, from the Export Boundary 
Conditions to Shapefile window, 
browse to where you want to save the 
file and enter a file name. Set Shape 
Type to “Polygon (model cells)” and 
check the box “Include All Layers”. 
(For this macro, leave the other boxes 
unchecked and leave the default values 
for database fields.) Finally, press “OK” 
to export the SFR2 data. A pop-up box 
with the message “Shapefile exported 
successfully” will appear.

Running the macro
From the ArcToolbox window, open Flux Calculations and 
double click FluxDifferences to launch the macro (see 
screenshot). 

Select the appropriate output folder and input files as 
follows:

Folder for data output: Browse for and select the folder 
you would like the final shapefile to be saved to. Do not 
select a file in the destination folder, just the folder.

Your initial data file: Browse for the shapefile containing 
the initial SFR2 flux conditions (for example, 2010 steady-
state conditions). Be sure to select the .shp file extension 
for this shapefile. This is the file to which changed SFR2 
conditions will be compared. 

File for comparison: Browse for the shapefile containing 
the SFR2 flux conditions for comparison. This would be the 
file that represents streamflow under a changed condition 
such as adding wells. 

Export boundary conditions

Select files and output folder location, then click OK to run the macro

TIP: Copy the file path from the “Folder 
for Data Output” to the “Output File,” 
add a backslash (“\”), then add the file 
name to the end. Be sure to add the 
suffix “.shp” after the file name.

NOTE: Make sure that all 
input data use the same 
coordinate system.
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File to determine locations: Browse for the shapefile 
containing point locations of the spots you’re interested in 
performing the SFR2 comparison. Make sure the locations 
of comparison points are located completely within SFR2 
model cells.

Output file: Enter the full file path and file name of the 
output file. This is most easily done by copying the file 
path of the Folder for Data Output and adding the file 
name onto the end. Be sure to add a backslash (“\”) before 
the file name and the suffix “.shp” after the file name (see 
screenshot).

Viewing macro results
To view results, add the newly created shapefile to an 
ArcMap session and open the attribute table. GWDiff is 
the difference in groundwater baseflow to each SFR2 
cell selected for comparison (equivalent to flux (“F”) as 
described in the “Understanding Streamflow Reporting” 
section), while SDiff is the difference in cumulative surface 
water flow of every SFR2 cell upgradient of and including 
the SFR2 cell selected for comparison (equivalent to “flow,” 
as described in “Understanding Streamflow Reporting”). 
Units of flow will be in cubic feet per day, the same as the 
SFR2 data originally exported from Groundwater Vistas.
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