
Kenneth R. Bradbury 
Anna C. Fehling 
Michael J. Parsen

A Groundwater Flow Model for the Little  
Plover River Basin in Wisconsin’s Central Sands

User’s Manual

Bulletin 111-supplement • 2017

W I S C O N S I N  G E O L O G I C A L  A N D  N A T U R A L  H I S T O R Y  S U R V E Y





Contents

Introduction    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   1

Additional resources   .     .     .     .     .     .     .     .     .     .     .     .     .   1

Background information and settings     .     .     .     .     .     .   2

Model layers    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .    2

Model units, orientation, and GIS options   .     .     .     .   2

Steady-state and transient models   .     .     .     .     .     .     .   2

Technical setup     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .  3

Newton Solver    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     3

Directories    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   3

Map files   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   4

Running the model     .     .     .     .     .     .     .     .     .     .     .     .     .     .   5

By running the USGS executable  
(.exe) file in Vistas   .     .     .     .     .     .     .     .     .     .     .     .     .     .    5

By running the .dll file in Vistas    .     .     .     .     .     .     .     .     6

Viewing model results    .     .     .     .     .     .     .     .     .     .     .     .    7

Run time   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   7

Model output   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   7

Viewing and editing model features     .     .     .     .     .     .     .  8

Streamflow routing (SFR2 Package)   .     .     .     .     .     .     . 8

Other surface water features    .     .     .     .     .     .     .     .     .     8

Wells    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .    8

Adding a new well    .     .     .     .     .     .     .     .     .     .     .     .     . 8

Editing an existing well   .     .     .     .     .     .     .     .     .     .     .   9

Removing an existing well    .     .     .     .     .     .     .     .     .     9

Recharge    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . 9

Hydraulic conductivity   .     .     .     .     .     .     .     .     .     .     .     10

Understanding streamflow reporting  
(SFR2 Package)    .     .     .     .     .     .     .     .     .     .     .     .     .     .     . 10

Particle tracking using MODPATH     .     .     .     .     .     .     .     . 12

Calculating drawdown (comparing scenarios)     .     .    16

Transient simulations     .     .     .     .     .     .     .     .     .     .     .     .     17

Best practices for  
successful transient runs   .     .     .     .     .     .     .     .     .     .     . 17

Technical setup    .     .     .     .     .     .     .     .     .     .     .     .     .     .     17

Initial heads    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .  17

Output control    .     .     .     .     .     .     .     .     .     .     .     .     .     . 18

Running the transient model   .     .     .     .     .     .     .     .     .  19

By clicking on the USGS executable (.exe) file   .     19

By using a Windows batch (.bat) file    .     .     .     .     .   19

Monitoring a transient run    .     .     .     .     .     .     .     .     .  19

Looking at transient output   .     .     .     .     .     .     .     .     .     20

Plotting hydrographs    .     .     .     .     .     .     .     .     .     .     .     .  21

Using Vistas targets or monitoring wells for head 21

Using GAGE Package for stream hydrographs   .   23

Changing the name file    .     .     .     .     .     .     .     .     .     .   25

Editing transient model parameters    .     .     .     .     .     .  25

Changing recharge and boundary conditions    .   25

Adding transient wells   .     .     .     .     .     .     .     .     .     .     . 26

Changing well pumping   .     .     .     .     .     .     .     .     .     .  27

ArcMap SFR2 baseflow comparison macro     .     .     .     .  28

What the macro does    .     .     .     .     .     .     .     .     .     .     .     .   28

Installing the macro   .     .     .     .     .     .     .     .     .     .     .     .     . 28

Files needed to run the macro   .     .     .     .     .     .     .     .     28

Exporting SFR2 data from Groundwater Vistas    .  28

Running the macro    .     .     .     .     .     .     .     .     .     .     .     .     .  29

Viewing macro results    .     .     .     .     .     .     .     .     .     .     .     . 30

References    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .    30



Suggested citation:

Bradbury, K.R., Fehling, A.C., and Parsen, M.J., 2017, A groundwater 
flow model for the Little Plover River basin in Wisconsin’s Central 
Sands—user’s manual: Wisconsin Geological and Natural History 
Survey Bulletin 111–Supplement, 30 p.

Published by and available from:

Wisconsin Geological and Natural History Survey
3817 Mineral Point Road  n  Madison, Wisconsin 53705-5100 
608.263.7389  n  www.WisconsinGeologicalSurvey.org 
Kenneth R. Bradbury, Director and State Geologist

ISSN: 0375-8265 
ISBN: 978-0-88169-985-2

NOTE: The Wisconsin Geological 
and Natural History Survey 
obtains its Groundwater Vistas 
licenses from ESI; however, 
several other providers also 
distribute the software. 

We do not endorse one product 
over others.



1

Wisconsin Geological and Natural History Survey

Introduction

This document provides basic instructions and recom-
mendations for running the steady-state and tran-
sient versions of the Little Plover River (LPR) ground-

water flow model, including use of the Groundwater Vistas 
(Vistas) user interface. The model is a state-of-the-art 
groundwater flow and optimization model for the Little 
Plover River basin in Portage County, Wisconsin. The 
steady-state model was designed to represent average 
groundwater conditions given a recent time period; the 
transient model represents one calendar year, with calibra-
tion focusing on 2014, but can be modified to simulated 
longer time periods or different years.

This publication is intended to assist technical users 
in running the model; for a comprehensive discussion 
about the development, construction, and calibration of 
the model, refer to the modeling report, A Groundwater 
Flow Model for the Little Plover River Basin in Wisconsin’s 
Central Sands (Bradbury and others, 2017). 

The model can be run directly using native MODFLOW 
files, but most users will need a graphical interface, 
such as Groundwater Vistas, to view and edit model 
input and results. A version of the Groundwater Vistas 
model including all necessary files, as well as the native 
MODFLOW files, are available for download from the 
UW-Box folder dedicated to the LPR model: https://
uwmadison.app.box.com/v/little-plover-river.

This report references Groundwater Vistas as a method 
to modify datasets and visualize model output. Vistas is a 
Windows-based graphical user interface using a series of 
embedded windows and tabs. Accessing various menus 
requires that the user select (mouse click) through a 
menu series, and in this manual we express these series in 
sequence. For example, Model > MODFLOW > Packages 
means that the user would click on the Model tab, then on 
the MODFLOW tab, then on the Packages tab to bring up 
the menu of interest.

This model was last modified using version 6.93 build 34 
of Vistas, so users should update to at least this version of 
Vistas before attempting to run the model.

Additional resources
Groundwater Vistas (software)

The Help menu at the top of the screen offers 
extensive documentation and assistance 
troubleshooting problems.

Groundwater Vistas: Online user manual 
groundwatermodels.com/ 
Groundwater_Vistas.php 

Environmental Simulations Incorporated  
(developer of Groundwater Vistas) 
groundwatermodels.com

Technical support, webinars, and seminars 
for Groundwater Vistas.

MODFLOW: Online guide (USGS) 
water.usgs.gov/nrp/gwsoftware/ 
modflow2000/MFDOC

MODFLOW: Report (USGS) 
pubs.usgs.gov/tm/2005/tm6A16

https://uwmadison.box.com/dane-groundwater-model
https://uwmadison.box.com/dane-groundwater-model
http://www.groundwatermodels.com
http://water.usgs.gov/nrp/gwsoftware/modflow2000/MFDOC/
http://water.usgs.gov/nrp/gwsoftware/modflow2000/MFDOC/
http://pubs.usgs.gov/tm/2005/tm6A16/index.html
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Background information and settings

Before you begin, you may find it helpful to familiarize 
yourself with the model layers used, as well as key 
settings and a brief comparison of the two condi-

tions—steady state and transient—for which the model 
was calibrated.

Model layers
The LPR model has three layers, which represent the fol-
lowing specific hydrostratigraphic units:

The sand and gravel aquifer is represented by two layers 
of approximately equal thickness to improve simulation of 
vertical gradients and flow near surface water features. All 
model layers are treated as continuous across the model 
domain. In places where specific formations, such as the 
Cambrian sandstone, are absent (eroded away), the model 
layer thickness is set to 1 ft and the layer made effectively 
transparent by assigning hydraulic conductivity values 
equal to those of the layer above. The crystalline rock 
below the sandstone forms the base of the model.

Model units, orientation,  
and GIS options
The model units are in feet and the time unit is days, 
which can be viewed here: Model > MODFLOW > Package 
Options, under the Basic tab. The real-world spatial units or 
map units (called “site coordinates” in Vistas) are in meters. 
This is important to remember when 
importing or exporting basemaps, well 
locations, or other features into or out 
of Vistas. The coordinates of imported 
features need to be in meters and coordi-
nates of exported features will be output 
in meters if the output is a shapefile. 
By contrast, if you are exporting ASCII 
grid files, such as a Surfer grid, these will 
be output in model coordinates (feet), 
which do not reflect the selected offset 

coordinate system. Attributes, like hydraulic conductivity 
or recharge, are reported in ft/day.

To orient the model properly with map files when export-
ing to GIS, the GIS options (under Edit > GIS Options…) 
should be set as shown in the screenshot.

The projection file is a GIS projection file (.prj) that specifies 
the correct GIS coordinates. You can leave this blank if you 
prefer to project the output shapefiles later or browse for a 
desired .prj file that you are currently using. We commonly 
use NAD 83 HARN Wisconsin TM in meters.

The model has a uniform cell spacing of 100 feet on a side. 
There is no grid rotation.

Basic information about the model grid (number of rows, 
columns, layers, cells), grid spacings, and model coordi-
nates are summarized in the Model Summary window 
(Model > Model Information).

Steady-state and transient models
The LPR model was calibrated to both steady-state and 
transient conditions. The steady-state model represents 
average equilibrium conditions where heads or flows do 
not change over time, while the transient model is capable 
of accounting for changes in head or flows over time. The 
steady-state model was developed first and is generally 
calibrated to average hydrogeologic conditions between 
2010 and 2014; the anomalously dry conditions of 2012 
were not included. The steady-state model served as the 
starting point for transient calibration, which simulates 
the 2014 calendar year. Calibration targets used for history 
matching included heads, stream flows, and lake stages.

While some sections of this guide are relevant to both 
model conditions, the text generally refers to the steady-
state version. For information that is exclusively about 
the transient model, see the section titled “Transient 
Simulations.”

Layer Unit simulated

1 Upper unlithified sand and gravel  
(glacial deposits and alluvial materials)

2 Lower unlithified sand and gravel  
(glacial deposits and alluvial materials)

3 Cambrian sandstone

Orient the model with map files when exporting to GIS.
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Technical setup
Newton Solver
This model uses the USGS Newton formulation of 
MODFLOW-2005 called MODFLOW-NWT. This is a sophisti-
cated solver that is intended for problems involving drying 
and rewetting of cells. In Vistas, this solver is included in 
Model > MODFLOW2005 > Packages. While MODFLOW-
NWT is already selected in the LPR model, it is important 
to understand where to activate the Newton Solver. To 
implement it in Vistas, the checkbox next to “Use Upstream 
Weighting Package (UPW) and Newton Solver (NWT) 
instead of LPF Package” must be checked in the Model > 
MODFLOW2005 > Packages window. 

The solver parameters are set under the Model > 
MODFLOW2005 > OPTIONS > NWT General tab. However, 
these options have been optimized for best model per-
formance and in general should not be changed. Note 
also that the solver unit number, which MODFLOW uses 
to keep track of input and output files, is still set under 
the Model > MODFLOW > Packages tab even though the 
solver method specified on that tab is ignored. 

Directories
Be sure to properly set up the working directory prior to 
running the model on a new machine (Model > Paths 
to Models). The working directory is the folder where all 
output files will be stored. The executable files are also 
set up using the Paths to Models box; this is described in 
a separate section (“Running the Model”). You may also 
choose to change the root file name for the output files 
under Model > MODFLOW > Packages.

Check box to activate Newton Solver
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Map files
The steady-state model is loaded with three map files 
already in Vistas .map format. These files must be kept in 
a separate directory and loaded when Vistas starts up. 
Several other map files have been included that you may 
elect to import.

The map files include the list shown below.

Two of the files we have provided are in bitmap (.bmp) 
format. Only one bitmap file may be loaded at a time. To 
load a bitmap file, select File > Map > Bitmap. You will 
be prompted to enter the map coordinates. Note that 
although the bitmap is in meters, the coordinates must be 
entered in feet. We have provided the coordinates in the 
file “BMPconverter.xls.” Copy and paste from this spread-
sheet into the Vistas window. Additional instructions 
(“How to Add a Bitmap as a Basemap”) are also included 
with the map files.

To load additional maps, go to File > Map and select the 
format of the map you want to import. This allows you to 
browse for a map and add it to Vistas. All maps that are 
loaded are viewable in Plot > Map Overlays…. From this 
window you can select to draw, not draw, or delete indi-
vidual maps. You can also change the thickness of the map 
lines. The display of maps can also be controlled by going 
to Plot > What to Display… and selecting or deselecting 
the box Display Base Maps. For a map to be viewable it 
must be set to Draw in the Plot > Map Overlays window.

Map files included with the model

File name Description
LPR_HUC_watershed.map LPR basin 12-digit HUC (hydrologic 

unit code) watershed

Port_Co_maj_roads.map major roads (Portage Co.)

Port_Co_min_roads.map minor roads (Portage Co.)

Del Monte app areas.map Del Monte irrigation application areas

Port_co_lakes.map lakes (Portage Co.)

Port_Co_streams.map streams (Portage Co.)

LPR_ortho_bitmap_base.bmp orthophoto (model area) 

LPR_topo_bitmap_base.bmp topographic map (model area)
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NOTE: You must use version 
1.0.9 of the USGS NWT Solver 
(MODFLOW-NWT). Newer versions 
may not work. The program is 
included with the model files.

Running the model

There are two common ways of running the LPR 
groundwater model. The first is using the native 
executable file (MODFLOW-NWT.exe) from USGS. 

This method is faster, but requires some initial setup and 
does not display onscreen results of how the model is 
running. In general, we recommend this method as it uses 
the “official” and most up-to-date USGS solver. The second 
method is using the MFNWTWIN32.dll executable supplied 
with Vistas. This option takes longer to run but is easy to 
set up because it is the default method in Vistas. The two 
methods are described in more detail in the following 
sections. Two additional methods that are less commonly 
used are described in “Running the Transient Model.”

By running the USGS  
executable (.exe) file in Vistas
The model can be run in Vistas using the executable file 
from USGS (MODFLOW-NWT.exe or MODFLOW-NWT_64.
exe). This method requires that you change two settings in 
Vistas and understand a bit more about how the execut-
able file reads and writes all the other files using the name 
(.nam) file. It displays only limited feedback during the run. 
However, you can check on the progress of a model run by 
opening the list (.lst) file. For more details, see instructions 
under “Monitoring a Transient Run.”

To run the model in this way, you first need to download 
the appropriate .exe file from the MODFLOW folder on 
https://uwmadison.app.box.com/v/little-plover-river and 
save to your computer. 

In Vistas, create datasets by clicking on Model > 
MODFLOW > Create Datasets. This will create a number of 
files including a name (.nam) file which are saved in the 
working directory (see “Directories”). The name file is a list 
of all the input and output files needed to run the model. 
Open the directory to confirm the name file is there. 
Then, in Model > Paths to Models (see screenshot), set 
the MODFLOWwin32 Option to “Do Not Use,” and set the 
MODFLOW path to wherever the MODFLOW-NWT_64.exe 
file is saved. In the Command Line box, enter the name file. 

Settings used to run the USGS executable file

https://uwmadison.box.com/dane-groundwater-model
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Once this has been set up, you can run the model (Model 
> MODFLOW > Run Model). A DOS window will pop up to 
show you the model has started running (see screenshot). 

Note that the following message will immediately pop up 
in Vistas: “MODFLOWwin32 is finished! Process the results?” 
This message can be misleading because the model is 
running using the executable file, not MODFLOWwin32. 
You can either wait for the model to run before clicking 
“yes”, or you can click “no” to make the box disappear. This 
won’t interrupt the run and will let you perform other tasks 
on the computer while the model runs in the background.

By running the .dll file in Vistas
This method is easiest to implement, as it is the default 
method in Vistas. It is visually more satisfying because it 
yields a continuous readout of what the model is doing 
and the error criteria as they change. This comes at a cost 
though, as the computer must use overhead to write to 
the screen, so running the steady-state model takes a few 
minutes longer than the other method, and can essentially 
tie up your computer, making multitasking very slow. In 
addition, it does not use the official USGS solver so may 
give slightly different results or be less computationally 
stable than the USGS solver.

To use the Vistas .dll file, go 
to Model > Paths to Models 
(see screenshot) and set the 
MODFLOWwin32 option 
to Run-Execute. Next, set 
the Path and Code Name to 
MFNWTWIN32.dll. You will 
need to browse to find the 
.dll file in the folder where 
you installed Vistas on your 
computer. You do not need 
to enter anything in the 
command line. 

From here you can create 
datasets and run the model 
through the Model > 
MODFLOW menu.

DOS window showing the model running

Settings used to run the .dll file in Vistas



7

Wisconsin Geological and Natural History Survey

Viewing model results
After running the model, you will select what results to 
import (see screenshot). Check the box next to the files 
you wish to import. If you are looking at flows, you must 
import the cell-by-cell flow file.

Run time
Run time depends on the processing speed of the com-
puter used, other processes running on the computer, 
and the complexity of the MODFLOW problem. The 
steady-state LPR model generally runs in under 3 minutes 
on a typical 64-bit machine. Longer run times will occur 
if model stresses are substantially changed by adding or 
removing wells.

Model output
Running the model produces a number of ASCII output 
files that contain useful information. The main binary files 
(.hds, .ddn., and .cbb) are used to import heads, draw-
down, and cell-by-cell flow into Vistas. The list file (.lst) 
is another useful file, which can be opened using a text 
editor to view the model budget at the bottom of the file.

Additional output files can be specified by editing the 
output control file. To edit the output control file, go to 
Model > MODFLOW > Package Options…, on the Output 
Control tab, check the box next to “Use Custom Output 
Control,” and specify the number of custom steps. By doing 
this, the default settings are deactivated and you will need 
to set up the output control under Model > MODFLOW 
> Custom Output Control. Custom output control is 
most useful during transient runs and is addressed in the 
“Transient Simulations” section of this manual.

Select results to import for viewing



8

Little Plover River Basin Groundwater Flow Model—User’s Manual

Viewing and editing model features
Streamflow routing (SFR2 Package)
All internal streams and several drainage ditches are 
routed using the Streamflow Routing (SFR2) Package in 
MODFLOW, which accounts for base flow accumulated 
from stream leakage. An important feature of the SFR2 
Package is that streams can lose water and even go dry if 
the groundwater head 
drops below the stream 
base or the head in the 
stream drops to the 
stream base.

Note that modeled flow 
in streams represents 
baseflow only, and 
runoff from storm 
events is not simulated. 
However, there is little topographic relief and high connec-
tivity between surface water and groundwater in the Little 
Plover River basin. Baseflow was estimated to be approxi-
mately 80% of total flow in the Little Plover River (Bradbury 
and others, 2017).

A discussion on how to view SFR2 output follows in 
“Understanding Streamflow Reporting (SFR2 Package).” 

Users may wish to manually add discharges at discrete 
locations to represent human-made 
discharges to the LPR. This can be 
manually entered in the Model > 
MODFLOW2000 > SFR Segment 
Data… window in the Flow column. 

Other surface water features
Lakes are simulated as high-hydraulic conductivity fea-
tures (1x106 ft/day) in layer 1. You can view these features 
by selecting Props > Hydraulic Conductivity. When repre-
sented in this way, lakes are essentially a reflection of the 
water table. One wetland, the Jordan Swamp, is repre-
sented by the MODFLOW Drain Package (to view, see BCs 
> Drain). Drains are head-dependent flux boundaries that 
can only remove groundwater from the system. 

Wells 
This model uses the standard MODFLOW Well Package 
(WEL). To view a well in Vistas, the Analytic Element (AE) 
button must be selected and you need to be in the model 
layer(s) from corresponding to the open, or uncased, 
interval of the well. Click on the well symbol to view its 
properties. 

Adding a new well
To add a new well, you will need to activate the Add Well 
tool. To do this, zoom in to where you would like to add 
the well, and click AE > Well. Then click the mouse button 
where you would like to insert the new well; a pop-up 
window will appear for you to add the necessary infor-
mation about the new well. As shown in the screenshot, 

NOTE: Routed streams are 
identified by numbered 
segments and reaches. 
The number and order 
of these reaches is very 
important and should not 
be changed.

Adding a new well—Basic Data tab settings
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set the exact coordinates of the new well location (X, Y), 
the model layers corresponding to the open interval of 
the pumping well (Top Layer of Screen, Bottom Layer of 
Screen), and the steady-state pumping rate. A negative 
pumping rate represents a withdrawal from the ground-
water system, while a positive pumping rate represents an 
injection. Pumping rates must be entered in cubic feet per 
day, and so a unit conversion is typically necessary. In this 
tab you can also name the well. Keep the default settings 
for all other fields and tabs. For adding a transient well, in 
which pumping rates change with time, see the “Transient 
Simulation” section of this manual.

Editing an existing well
To edit an existing well, such as increasing the pumping 
rate, click on the well to open the Well Information window 
and make the changes to the Basic Data tab.

Removing an existing well
To remove existing wells, they first need to be selected. 
Either click on a single well directly, or select multi-
ple wells using Edit > Select By or Edit > Select All. 
Then press the delete key to remove the wells. You 
can confirm that wells were removed by checking the 
total number of wells listed on the model informa-
tion window (Model > Model Information). If you are 
interested in deleting all wells, for example to simulate 
predevelopment conditions, you can simply select 
all wells (Edit > Select All > Well) and press delete.

Recharge
Groundwater recharge varies spatially across the land-
scape in this model. Initial values of recharge were taken 
from a modified soil-water-balance model (see Bradbury 
and others, 2017), and were adjusted regionally during 
model calibration. In this model, recharge represents deep 
drainage from the soil zone, or the water that actually 
reaches the water table. Evapotranspiration and applied 
irrigation are explicitly accounted for in the recharge 
values and are not directly input into MODFLOW. Refer 
to the model report for a more detailed discussion of 
recharge and how it can be applied to land use analysis.

Recharge can be viewed by selecting Props > Recharge. 
The lower left corner displays recharge in units of feet/day. 

Users may wish to modify the recharge to simulate the 
steady-state conditions following land development or a 
change in climate. However, recharge should be modified 
with caution due to the complexity of the initial value dis-
tribution and the unknown consequences of future climate 
change (such as increased pumping during a drought).

To directly edit recharge in a specific cell or area, select 
Props > Set Value or Zone. The screenshot below shows 
how to set recharge at a single cell. To set a given value of 
recharge over a larger area the user can choose Window 
to highlight a rectangular area or Digitize Polygon to 
highlight an irregular area and then set the recharge in the 
selected area to a single uniform value using the Change 
Matrix Values tool below.

Model-wide changes to recharge may be simulated using 
multipliers. To do so, first confirm that Recharge is selected 
from the Props menu. Then, select Props > Property Values 
> Recharge Multipliers. Enter the desired multiplier. 

In the Little Plover River model it is likely that users might 
want to add or subtract recharge to a pre-existing con-
dition (such as by increasing irrigation to a field) rather 
than setting nodes to a common value. Vistas has a tool 
called the matrix editor to do this. To access it, select Props 
> Property Values > Matrix Editor. This brings up a matrix 
spreadsheet that allows you to perform math calculations 
on specific blocks of cells. The example on the following 
page shows how the matrix editor would be set up to add 
0.001 ft/day of recharge to a range of cells from row 525, 
col 363 to row 552, col 389 in layer 1. Note that the same 
method works for other gridded properties as well. The 
area of change must be rectangular to use this method. 
For irregular or circular areas it will usually be necessary 
to set up the recharge 
array outside of Vistas 
using GIS or other 
software and then 
import the new array.

Setting recharge for individual cells

Use multipliers to make global changes to recharge
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Hydraulic conductivity
Hydraulic conductivity varies spatially across the land-
scape. To view hydraulic conductivity values, select Props > 
Hydraulic Conductivity. Values are displayed in units of ft/
day in the lower left corner. 

Understanding streamflow 
reporting (SFR2 Package)
The Streamflow Routing (SFR2) Package is a powerful 
modeling package that calculates the amount of water 
entering (from groundwater) and leaving (to ground-
water) each stream cell, as well as the cumulative flow rate 
in the stream at each stream cell. This section describes 
how to use SFR2 output to determine the mass balance of 
water entering and leaving each stream cell in the model. 
Understanding how groundwater and surface water inter-
act is an important component of many water resource 
evaluations. 

Following a run, once model results (including the cell-
by-cell flow .cbb file) have been imported, Vistas can be 
queried to show the simulated streamflow at any stream 
point. To do this, you must turn on Stream Boundary 

Condition (BCs > Stream) or specify Stream in the drop-
down Boundary Condition box. Next, hover the cursor over 
any stream node (you must be in the model layer contain-
ing the SFR2 stream node, typically layer 1 or 2). The lower 

Matrix editor in Vistas

TIP: Ordinarily, Vistas reports streamflow in the 
base model units (feet and days in the case of 
the Little Plover model). This means that stream-
flows and flux are reported as cubic feet per 
day as large numbers such as 8.64x104 cubic ft/
day, which might not be intuitively meaningful. 
However, Vistas has an option of setting a mul-
tiplier to change the displayed value. Select Plot 
> What to Display and near the bottom of the 
pop-up menu there is a box titled Multiplier on 
Status Bar Fluxes. The reported flux values will 
be multiplied by this number. So, for example, to 
change the reported units to cubic feet per second 
you would enter 1/86,400 sec/day, or 1.157x10-5. 
Then the streamflow will be reported in the more 
common units of cubic feet per second (cfs). 
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left corner of the screen will report the following informa-
tion about the node:

■■ s (segment) = a long segment of the stream (we’d 
normally call this a reach)

■■ r (reach) = an individual node along that segment

■■ H (head) = the hydraulic head in the stream

■■ F (flux) = flux into or out of that particular reach 
(node). Note that a negative value means flux out of 
the groundwater system and into the stream node; 
a positive value means flux into the groundwater 
system and out of the stream node. 

■■ Flow = accumulated baseflow in the stream. Flow 
equals the sum of all individual node fluxes from the 
first stream node (upstream) up to and including the 
node of interest. This number should always be posi-
tive, or zero if the stream is dry.

Based on the screenshot at right, the stream-
flow report should be understood as follows:

■■ s (segment) = 715

■■ r (reach) = 4

■■ H (head) = 851.63 feet above mean sea 
level

■■ F (flux) = –1.397 x 104 cubic ft/day (again, 
negative flux means water is moving out 
of the groundwater system and into the 
stream)

■■ Flow = 3.642x105 cubic ft/day (accumu-
lated baseflow of stream up to, and includ-
ing this node)

To better understand this, go to the most 
upstream segment of any stream and hover 
the cursor over that node. For this node, flux (F) 
should equal the negative of flow as reported 
by Vistas. Some headwater SFR2 nodes may 
report flux and flow equal to zero, indicating 
that they are simulated as dry. 

To view all SFR2 cells at once go to the 
Boundary Conditions (BCs) drop-down window 
(select Streams), press Options… and check the 
box Display All BCs When Viewing Layer 1. This 
will allow you to view all SFR2 cells as long as 
you are in model layer 1. As you drop down to 
lower layers, only the SFR2 cells present in that 
layer will be visible. To see which SFR2 cells are 
present only in layer 1, uncheck the box (see 
screenshot).

To manipulate and study streamflow results, 
it is best to export the streamflow data as 

a shapefile from the Boundary Conditions (BCs) drop-
down window (BCs > Export > Shapefile) and work 
with the data in GIS. When exporting a shapefile of 
the streamflow results, name the shapefile accord-
ingly and select the shape type. Polygon (model cells) 
will export polygons representing the model cells 
while the type Point (nodes) will export a point feature 
class of nodes located at the center of each stream 
cell. Either way the same streamflow attributes (s, r, 
H, F, and flow) will be exported for all stream cells.

Sample streamflow report

Uncheck box to view SFR2 cells present in layer 1 only

NOTE: We have developed an ArcGIS macro for 
easily comparing streamflow results. See ArcMap 
SFR2 Baseflow Comparison macro.
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Particle tracking using MODPATH

Particle tracking is a powerful way to help visualize 
the direction of groundwater flow and evaluate the 
impact of new or existing wells, simulate flow away 

from a landfill, or towards a subdivision. Particles can be 
simulated in both forward and reverse particle tracking 
mode, allowing the user to investigate groundwater flow 
both up-gradient and down-gradient from a specific 
feature of interest. This chapter provides a basic overview 
for how to perform particle tracking using MODPATH in 
Groundwater Vistas.

Currently the model is compatible with MODPATH 
version 5 (which is included with Vistas). Use the 
MP5WIN32.dll executable in Model > Paths to Models.

Add particles to your model by going to the Analytic 
Element (AE) drop-down pane (AE > Particle) and selecting 
an appropriate shape for inserting particles. Particles can 

be inserted as single particles, lines, circles, window or 
digitized polygon features. Circles of particles work best for 
delineating capture zones of wells, while lines, windows 
and digitized shapes of particles work well for delineating 
flow paths to or from larger features, such as lakes and 
streams. 

The following example demonstrates how to perform a 
capture zone (area of contribution) analysis for a well by 
delineating a 100-year time-of-travel area.

Start by setting up the particle options under Model > 
MODPATH > Particle Options…, setting the Direction of 
Tracking to Reverse, checking the box Limit Particle Travel 

NOTE: MODPATH v.5 will crash if the program encounters dry 
cells. To avoid this bug, before running MODFLOW, go to Model 
> MODFLOW2005 > Options, select the LPF Options tab, and put 
a check in the box next to “Set Head to HDRY in cells with small 
saturated thickness (IPHDRY)” (see screenshot).

Check box to keep dry cells from causing MODPATH to crash

TIP: If the box highlighted below 
is checked, the resulting heads 
cannot be used to calculate 
drawdown between two model 
runs because many wells will start 
out dry. To get around this, see the 
section “Calculating Drawdown.”
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Time and entering Max. Travel Time in days (100 years 
x 365 days = 36,500 days). If you do not limit the parti-
cle travel time in this window, the particle traces will be 
infinite. We recommend leaving all the other check boxes 
and settings as shown in the screenshot.

If you are viewing particle traces in Vistas only (not 
exporting as a shapefile), you may wish to not select 
a maximum travel time since this allows you to view 
any desired particle travel time by adjusting Maximum 

Time in Plot > Particles > Options under the Display 
tab. A number of other particle display options are 
available in this window, including color coding par-
ticles based on model layer or adding arrows and 
time postings along the particle travel path.

Once you have set the particle options in Model > 
MODPATH > Particle Options…, the next step is to insert 
circles of particles for the well of interest. Under the 
Analytic Element (AE) drop-down window, select AE > 

Particle > Circle. When you click on Circle, 
the window will disappear and you can 
hover over the model space and click a 
spot where you would like to add a circle of 
particles. If you continue to hold down the 
button, you can adjust the diameter of the 
particle circle. When you release the mouse 
button, a pop-up window will appear next 
to the particle circle where you can enter 
circle trace information (see screenshot on 
the next page). 

Settings for particle tracking

Displayed maximum travel time can be adjusted here if 
viewing particle traces in Vistas only (not exporting)
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The initial location and size of the particle circle is not 
critical since these settings can be adjusted in the pop-up 
window. You can also double-click on 
the particle circle (just as you would 
with a well) to reopen the window. 
As for wells, to select a particle circle, 
the Analytic Element (AE) tab must 
be selected and you need to be in 
the same model layer containing the 
particles.

Place the particles as close as possible 
to the center of the model cell. To aid in this, we recom-
mend making the model grid cells visible (go to Plot > 
What to Display, and check Display Finite-Difference Grid). 
While the well you may be interested in is not necessarily 
located in the exact center of the model cell (as in the 
screenshot below), the center of your particle circle needs 
to be in the center to correctly perform a particle trace for 
the well. This is because the numerical model solution is 
solved for the model node, which is located at the exact 
center of the model cell. One simple way to do this is to 

first make the diameter of your particle circle equal to 
the cell size (set the circle radius to 50 ft since the cell size 

equals 100 x 100 ft), and then manually 
adjust the spatial parameters (coordi-
nates X and Y) by trial and error until 
the circle exactly fits in the middle of 
the model cell. Once the particle circle 
is centered, the radius can be changed 
back to 20.8 ft. The radius of the par-
ticle circle should be 20.8-ft based on 
the size of the model cells (100 x 100 ft) 
and the principles of converging flow 

near a pumped well node (Prickett and Lonnquist, 1971). 

When doing reverse particle tracking to delineate capture 
zones for wells, we recommend using three circles of 10 
particles in each open interval layer of the well. In other 
words, if the well is open between model layers 1 and 2 
you would place three circles of 10 particles in both layers 
(a total of 6 circles and 60 particles). You will also need 
to specify the open interval of the well (top and bottom 
layers) and the Number of Vertical Release Points to 3. For 

Click on a particle circle to open the Circle Trace Information box

NOTE: The effective radius 
for the near-field of the 
Little Plover River model is 
calculated as 100 ft (model 
grid interval) ÷ 4.81 = 20.8 ft.

TIP: Specify the layer for adding 
particles directly from the pop-up 
window. This is often easier than 
clicking down to each model layer 
and adding circles for a particular 
model cell.
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this example, set the top layer to 1 and the bottom layer to 
2. Leave the remaining default settings as shown above.

If the particles are not visible after creating them, make 
sure that the checkbox Display Particle Starting Locations 
is selected in Plot > What to Display.

Now that you have created a particle circle, create 
MODPATH datasets (Model > MODPATH > Create Datasets) 
and run MODPATH (Model > MODPATH > Run MODPATH). 
Just as for running MODFLOW in Vistas, you can view the 
error/warning file by clicking “yes” in the pop-up window. 
Once MODPATH is finished running, particles can be dis-
played by selecting the checkbox Display Particle Traces in 
Plot > What to Display.

To export particles, go to File > Export…, type in a file 
name, select the appropriate file type (such as a shapefile, 
.shp), and save. If exporting as a .shp file, the next pop-up 
window will allow you to name the file and set the type of 
output to export (Result Type: Particle Traces). 

TIP: If working with exported 
particle traces in ArcMap, be 
sure to correct the location of 
the particles back to the real-
world coordinates at the center 
of your well of interest. If not, 
your particles will be offset by 
the same distance you moved 
them in Vistas to center them in 
the middle of the model cell.

Export particles to shapefile
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Calculating drawdown (comparing scenarios)

Drawdown calculations are performed to compare 
one set of water levels to another, such as compar-
ing predevelopment water levels to current-day 

conditions, or evaluating the impact of adding or remov-
ing wells. Regardless of the objective, it is important to 
follow the steps outlined here.

First, save and run a version of the model that reflects 
initial drawdown conditions. For example, if interested 
in determining current drawdown compared to prede-
velopment, then predevelopment drawdown (no wells) 
represents initial conditions. If interested in determin-
ing drawdown under an alternative scenario (say, wells 
removed or wells added), then the existing model rep-
resents initial conditions. (Refer to the section on wells in 
“Viewing and Editing Model Features” for more informa-
tion about changing these features in the model.)

When the initial-conditions run is complete, open a version 
of the model that reflects the changed drawdown condi-
tion (for example, well(s) added or well(s) removed). Next, 
go to Model > MODFLOW > Package Options > Initial 
Heads, set the initial head location to Read Heads Directly 
from Binary Head—Save File, and browse for the corre-
sponding file name. Select the .hds file that corresponds to 
the initial drawdown condition created earlier. As with the 
initial-conditions version, before running the model you’ll 
need to uncheck the box Set Head to HDRY in Cells with 
Small Saturated Thickness (IPHDRY). The drawdown com-
parison will only work if this HDRY option is unchecked for 
both the initial- and changed-condition runs.

Now create datasets, run the model, and import results 
for the changed-conditions version. Be sure to check 
the box to import the drawdown file when import-
ing results. Once results are imported, go to Plot > 
What to Display, check the box Display Contours of, 
and select Drawdown from the drop-down menu to 
display contours of drawdown. To display a color flood 
of drawdown, check the box Display Color Flood of 
and select Drawdown from the drop-down menu.

TIP: Before running the initial-conditions version, 
be sure to uncheck the box “Set Head to HDRY 
in cells with small saturated thickness (IPHDRY)” 
under Model > MODFLOW2005 > Options > LPF 
Options. Running the initial-conditions version of 
the model will generate a heads (.hds) file which 
will serve as starting heads in the subsequent 
model run under changed conditions.
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Transient simulations

The transient model simulates the year 2014. It uses 
one stress period for each month of the year, for a 
total of 12 stress periods representing 365 days. The 

number of time steps per stress period ranges from 2 to 
5, with the relative length corresponding to the number 
of days in the month. Recharge and pumping rates vary 
monthly. The model is described in additional detail in the 
modeling report. 

Be aware that transient simulations require significant 
model setup, and might require run times lasting several 
hours. When editing a transient simulation, model stability 
and convergence can be issues depending on the specific 
problem being investigated.

Best practices for  
successful transient runs
The following tips should help in setting up successful 
transient runs:

■■ Use initial heads as near to the final solution as possi-
ble. This should not be an issue unless major changes 
are made to the model.

■■ When editing model parameters, be sure to prop-
erly set up all transient data for each stress period. 
Failing to do this is a common mistake and will lead to 
model crashes. Properties with transient data include 
well pumping, recharge, streamflow routing, and 
boundary conditions. See “Editing Transient Model 
Parameters” for details.

■■ If using the model to plot hydrographs, use the GAGE 
Package to capture stream flow and other mass 
balance data rather than saving entire model mass 
balance at every location. (See “Using GAGE Package 
for Stream Hydrographs” for more details.)

■■ When using the GAGE Package, run Vistas using 
the native executable file and correct file settings 
as described in “Using GAGE Package for Stream 
Hydrographs.” 

Technical setup
Initial heads
A transient run should begin with initial (starting) heads 
taken from a previous successfully converged steady-state 
or transient run. During the initial run the Set Heads to 
HDRY in Cells with Small Saturated Thickness (IPHDRY) 
box in Vistas under MODEL > MODFLOW2005 > OPTIONS 
must be unchecked. Files built with this box checked are 
not suitable for starting heads, and models using such files 
for initial heads will probably not converge. Unfortunately, 
this is the opposite of what is needed for using MODPATH 
(see “Particle Tracking Using MODPATH”). Setting initial 
heads is the same for transient and steady-state. Select 
Model > MODFLOW > Package Options > Initial Heads, 
set the Initial Head Location to Read Heads Directly from 
Binary Head—Save File, and browse for the corresponding 
file name from the initial run.
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Output control
Output control is used to determine how often data 
is saved. You should not have to modify this unless 
you wish to save data more or less frequently. In 
a transient run, the files generated by Vistas are 
quite large if the model saves data from every time 
step. For example, the LPR model has a total of 38 
time steps, and if the heads and flows from each 
time step were saved it would be equivalent to the 
combined output of 38 steady-state models. To cut 
down on this output we use custom output control. 
As seen in the first screenshot, the Use Custom 
Output Control box has been selected in the Model 
> MODFLOW > Package Options > Output Control 
tab. The settings for output control are set to save 
the heads and mass balance at the end of each 
stress period. This is shown in Model > MODFLOW 
> Custom Output Control (see screenshot below). 

Sample custom output control settings

Check box for Custom Output Control
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Running the transient model
The model can be run as described for the steady-state 
model in “Running the Model,” unless you are using the 
GAGE Package, which requires the name file be modified 
(see “Using the GAGE Package for Stream Hydrographs”). 

This section describes a few additional methods to run the 
model, which can be used for either transient or steady-
state. They are included here as they are often useful for 
longer transient runs. 

By clicking on the USGS executable (.exe) file
The model can be run directly using the USGS MODFLOW 
executable file. This method allows the user to run the 
model without Vistas. Save the executable file (MODFLOW-
NWT_64.exe) in your working directory, then double-click 
on it, and enter the name file in the DOS command line. 
The model will begin running as described in “Running the 
Model.”

By using a Windows batch (.bat) file
Another way to start the model is by using a batch 
file. This method is handy if you are running a 
model repeatedly. To use this method, you need 
to prepare a Windows batch file by opening a text 
editor and saving with the extension .bat. 

Here is an example, called Runtransient.bat:

MODFLOW-NWT_64.exe Usethis_Trans_predevel.nam

MODFLOW-NWT_64.exe Usethis_Trans_2014_11_29_15.nam

In this case, the name files refer to two different models 
to be run. Assuming the name files have been set up 
correctly, this batch file will run two models, one after the 
other. To run the model this way, double-click on the batch 
file name. This will execute the model and add the name 
file automatically, saving some typing. This also allows you 
to run several models in a row while you are away from 
your computer.

Monitoring a transient run
This section describes how to monitor transient model 
runs that use the USGS executable file. Steady-state runs 
may be monitored in the same way, although they often 
finish running more quickly and monitoring is not needed. 

After running the model using the USGS executable (.exe) 
file, the DOS window will close when the model either 
finishes successfully or crashes. If it closes quickly (within 
a minute or so) there is likely an input problem. Successful 
transient runs might take as long as 1–2 hours depending 
on the simulation. To abort a run, press control-C in the 
DOS command line.

Because of these long run times, and because there is 
little screen feedback from the model, you might wonder 
whether it is actually running. 

There are three ways to track the progress of the run:

■■ Look at the stress period and time step numbers in 
the DOS window. The numbers should gradually 
increase, changing every few minutes.

■■ Look at the size of the list (.lst) file; it should gradually 
increase while the model is running.

■■ Use Windows Explorer (or another file viewer) to open 
the .lst file, then scroll to the bottom to see what the 
model is doing. Opening this file will not interrupt 
the model run, but you will need to refresh (close and 
reopen) the file to track ongoing progress. Refreshing 
the file is particularly important if the model is taking 
a long time between time steps. If the model is not 
converging during the time steps, you can determine 
this by checking to see where the model is slowing 
down, such as near a model cell with a problematic 
well or stream section. If you spot this behavior, there 
is usually no point in continuing; it’s best to abort the 
run (control-C) and fix the problem. For help diagnos-
ing problems, see “Additional Resources.”

Sometimes the model will crash, and might list some 
errors. Again, looking in the .lst file is a good way to track 
down errors. Often crashes are due to errors or omissions 
in the name file. 
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Looking at transient output
Transient output files (heads, drawdowns, mass balance) 
can be imported into Groundwater Vistas similar to steady-
state runs, with the difference that you must specify the 
stress period and time step desired for viewing. Be aware 
that import might be slow because the output files can be 
very large, and Vistas has to sort through the large files to 
load the correct time step. This model has 12 stress periods 
with up to 5 time steps each. You can choose the time step 
to display using the browse function under Import Model 
Results and highlighting the time desired.

Vistas also has a handy feature under the Plot menu that 
lets you switch between time steps (see screenshot at 
right).

Note that changing the stress period on the left sidebar 
only changes the displayed input values, not results. 

When importing results, choose the time step using the browse function 

A handy shortcut for switching 
between time steps

Changing the stress period in 
the sidebar changes displays 
input values only, not results
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Plotting hydrographs
Using Vistas targets or monitoring wells for head
For transient runs, users will probably want to generate 
hydrograph plots of drawdown, water levels, or stream 
flow at specific locations. For monitoring head, this may 
be done by adding a target or monitoring well under the 
Analytic Element window prior to running the model 
(AE > Target or AE > Well). A target is typically a loca-
tion where head or flux has been measured, and can be 
compared graphically to model results. Enter transient 
data by unchecking Target is Steady-State and clicking on 
the Transient Data button (see screenshot). You may also 
import data using the Import button.

Enter transient data by unchecking “Target is 
Steady State” box, then clicking the Transient 
Data button

Transient data entry area
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After loading the model results you can click on a target 
to see and/or export a hydrograph. To do this, first click on 
the target; this brings up the target menu. Then click on 
Graph to bring up the hydrograph (see screenshot below). 
Right-click on the graph to see export options.

Alternatively, you can add a well to monitor head (AE > 
Well). Check Monitor Head/Concentration vs. Time (see 
screenshot). Once you have run the model, view results 
using Plot > Hydrograph > Monitoring Well.

Monitor head by checking highlighted box

Click on a target to view its hydrograph;  
right-click on the graph to export
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Using GAGE Package for stream hydrographs
We recommend using the GAGE Package when plotting 
transient hydrographs of flow or stage. For hydrographs, 
all the mass-balance data must be saved for every time 
step. Saving such data for all locations and time steps will 
generate enormous cell-by-cell (.cbb) files. To avoid this 
problem, the GAGE Package will save the head or flow data 
only at specified stream nodes. Vistas includes an option 
to prepare the GAGE file, but writes all the data to a single 
large file. We have set up a gage file (Usethis_Trans_2014_
baserun.gag) that saves data at four specific points along 
the Little Plover River and stores each data set in a sepa-
rate file. The four points represent gages with discharge 
data at Kennedy Avenue, Eisenhower Avenue, Highway 51, 
and Hoover Avenue. 

A gage file may have the extension .gag or .dat. The 
screenshot at right shows the content and formatting of a 
typical gage file. 

To use the GAGE Package, the gage file and the specified 
output files must be indicated in the name (.nam) file. 
We have provided an example name file (Use_for_Gage_
package_Trans_2014_7_24_16.nam) for this purpose. You 
may use these files for running the Gage Package unless 
you change the root file name. The root file name can be 

found in Model > MODFLOW > Packages (see screenshot). 
If you change the root file name, you will need to create 
your own edited name file (see “Changing the Name File”). 
The gage file should only be changed if you wish to evalu-
ate a different stream location. If you choose to modify the 
gage file, we recommend reading the MODFLOW docu-
mentation here: http://water.usgs.gov/nrp/gwsoftware/
modflow2000/MFDOC/gage.htm.

segment
reach

output  
unit #

output flag

Number  
of gages

SAMPLE GAGE FILE  
(see MODFLOW documentation for details)

Gage locations 
(one line each)

View or edit the root file name
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The output files for the four gage locations will be saved 
in the working directory. The screenshot below shows the 
partial contents of the Eisenhower gage output file (Eisen.
dat). You can use another program, such as Grapher or 
Excel, to plot the hydrographs.

Partial contents of a gage output file

Reference modified name file when using GAGE Package

NOTE: When using the 
provided gage file, you must 
run the model using the 
USGS executable (.exe) file as 
you would for steady-state. 
However, you must refer-
ence the modified name 
file in the command line 
under Models > Paths to 
Models (see screenshot).
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Changing the name file
To change the name file, first create datasets in Vistas 
(Model > MODFLOW > Create Datasets). This will gener-
ate a name file similar to the one shown on the left in the 
screenshot below. Use a text editor such as Notepad to 
add the gage file name and appropriate output files. A text 
file with instructions has been included with the transient 
model files.

The new name file should look similar to the screen-
shot (below right), except “Trans_2014_7_24_16” will 
be replaced by your root file name. The yellow highlight 
shows the added lines. 

Save the edited name file with a different name that you 
will remember. Every time you create datasets, the original 
name file will be rewritten. By using a different name, you 
are able to run various scenarios without changing the 
name file. However, remember to edit the name file when-
ever you change the root file name.

The format of the name file is important; make sure the 
text editor does not change the format. Also, make sure 
the extension of the edited file is .nam. Some text editors 
will automatically change it to .txt or .dat; these will not work. 

Editing transient model parameters
Transient model properties must be set up for all stress 
periods. Properties with transient data include recharge, 
streamflow routing, boundary conditions, and well 
pumping. Basic changes to properties is discussed in 
“Viewing and Editing Model Features.” This section 
describes how to apply these changes to multiple stress 
periods. Note that boundary conditions cannot be 
changed within a stress period.

Changing recharge and boundary conditions
Users are cautioned that any changes to recharge in the 
transient model must be applied to all stress periods 
affected. Change the Stress Period box on the left side of 
the Vistas screen to view and edit the recharge for different 
stress periods. 

Likewise, boundary conditions need to be specified for 
each stress period affected. Just changing a boundary 
condition in the first stress period will not work. After any 
change you need to copy the change to all stress periods 
using the Vistas procedure: BCs > Modify > Copy Stress 
Period and then put in the range of stress periods you 
wish to copy to. The same technique applies to changing 
properties of streams.

Name file created by Vistas

Edited name file

ABOUT THE ENTRIES 

GAGE 28: References gage file, where “28” 
is the unit number assigned to the file by 
Vistas. “GAGE” must be written out.

DATA 45-48: Specifies the name of the 
output file for each gage and unit number 
(45-48) referenced in the gage file.
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Adding transient wells
For transient runs of the Little Plover model it is best to use 
the analytic element option in Vistas and import the wells 
directly from a GIS shapefile (AE > Import > Shapefile). 
The benefit of entering wells this way is that each well 
can penetrate one or more model layers as appropri-
ate for its well construction and depth and Vistas will 
apportion flow to each layer based on the layer transmis-
sivity contrast. Using this method, Vistas writes out the 
MODFLOW input (.wel file) using standard MODFLOW 
format, and will thus convert an analytic element in a 
well that spans multiple model layers into two or more 
MODFLOW wells, one for each layer. This can be 
confusing because it will cause the number of 
wells listed in the MODFLOW .wel file to be greater 
than the actual number of wells simulated. For 
example, the transient LPR base model simulated 
448 wells, but because some of these wells span 
multiple model layers, the MODFLOW .wel file lists 
621 wells. Vistas will report the actual number of 
wells by clicking MODEL > Model Information.

The Little Plover model contains several hundred 
wells, each with a unique pumping record. It is 
convenient to enter these wells using a shapefile 
containing the pumping record for each well on a 
single line. Below is an example of an appropriate 
format in the .dbf shapefile (such a file can be set up 
directly from the Wisconsin DNR well database). The 
following example only shows the first five stress 
periods, but continues in a similar pattern through 
the last stress period. There are 12 pumping rates 
(Q1, Q2, Q3…etc.), corresponding to the 12 stress 
periods in this run. The C1, C2, C3… columns are for 
concentration data, not used in the current model, 
so these columns are set to zero. 

To import these data into Vistas, use AE > Import 
> Shapefile and specify Well. Then browse for the 

correct shapefile. This will bring up the screen below. Make 
sure that you understand the data entry process, which 
can be confusing. In this example, for a model with 12 
stress periods, Vistas will look for the pumping data for 
stress period 1 in column Q1, the concentration in column 
C1, and will then look for the remaining pumping and con-
centration data for that well in the following 22 columns 
in the shapefile database (11 for Q and 11 for C). Be sure to 
check Vistas after you are done to be sure that the correct 
number of wells was entered and that the data are what 
you expect. Just click on any well symbol in Vistas to bring 
up the data for that well.

Partial contents of example shapefile for transient pumping import

Well import menu
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Changing well pumping
To edit transient pumping rates, click on the well and make 
sure the Pumping Rate is Steady-state box is unchecked. 
Click on the Transient Data button to enter transient 
pumping rates (see screenshot).

In the example shown below, the well is pumped at 
a different rate for each of the 12 stress periods. This 
particular well is not pumped at all during stress periods 
1 to 4 (representing January through April). Beginning 
in stress period 5 (May) the well is pumped during the 
summer months, but is idle again in the fall (not shown in 
screenshot).

To edit transient pumping rates, uncheck the “Pumping Rate 
is Steady-state” box, then click the Transient Data button

Example data for a well pumped at different rates for each stress period
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Export stream shapefiles

ArcMap SFR2 baseflow comparison macro

We’ve created a macro that runs in ArcGIS to calcu-
late streamflow changes at various sites through-
out the model. This section describes the macro 

and how to use it.

What the macro does
This ArcMap macro helps evaluate changes in streamflow 
between different model runs for any set of locations 
along the Streamflow Routing (SFR2) network. This is par-
ticularly useful when determining cumulative streamflow 
(baseflow contribution) at multiple stream locations.

Installing the macro
From any current session of ArcMap, open the ArcToolbox, 
right-click on the ArcToolbox icon in the upper left hand 
corner of the pop-up window, and select Add Toolbox. 
Next, select the Flux Calculations.tbx file from the ArcGIS 
folder included with the model files and press Open. This 
will add the macro to the ArcToolbox for the open ArcMap 

session; you’ll need to reinstall the macro each time you 
start a new ArcMap session.

Files needed to run the macro
To run the macro, you’ll need to export two shapefiles from 
Vistas—the initial SFR2 flux conditions (for example, 2010 
steady-state) and the changed SFR2 flux conditions (such 
as wells added). You’ll also need a shapefile containing 
the point locations where you are interested in extracting 
stream fluxes along the SFR2 network. 

Exporting SFR2 data from Groundwater Vistas
Under the tab BCs, highlight “Stream,” then click Export > 
Shapefile (see screenshot).
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Export boundary conditions

Select files and output folder location, then click OK to run the macro

TIP: Copy the file path from the “Folder 
for Data Output” to the “Output File,” 
add a backslash (“\”), then add the file 
name to the end. Be sure to add the 
suffix “.shp” after the file name.

NOTE: Make sure that all 
input data use the same 
coordinate system.

Then, from the Export Boundary 
Conditions to Shapefile window, 
browse to where you want to save the 
file and enter a file name. Set Shape 
Type to “Polygon (model cells)” and 
check the box “Include All Layers”. 
(For this macro, leave the other boxes 
unchecked and leave the default values 
for database fields.) Finally, press “OK” 
to export the SFR2 data. A pop-up box 
with the message “Shapefile exported 
successfully” will appear.

Running the macro
From the ArcToolbox window, open Flux Calculations and 
double click FluxDifferences to launch the macro (see 
screenshot). 

Select the appropriate output folder and input files as 
follows:

Folder for data output: Browse for and select the folder 
you would like the final shapefile to be saved to. Do not 
select a file in the destination folder, just the folder.

Your initial data file: Browse for the shapefile containing 
the initial SFR2 flux conditions (for example, 2010 steady-
state conditions). Be sure to select the .shp file extension 
for this shapefile. This is the file to which changed SFR2 
conditions will be compared. 

File for comparison: Browse for the shapefile containing 
the SFR2 flux conditions for comparison. This would be the 
file that represents streamflow under a changed condition 
such as adding wells. 
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File to determine locations: Browse for the shapefile 
containing point locations of the spots you’re interested in 
performing the SFR2 comparison. Make sure the locations 
of comparison points are located completely within SFR2 
model cells.

Output file: Enter the full file path and file name of the 
output file. This is most easily done by copying the file 
path of the Folder for Data Output and adding the file 
name onto the end. Be sure to add a backslash (“\”) before 
the file name and the suffix “.shp” after the file name (see 
screenshot).

Viewing macro results
To view results, add the newly created shapefile to an 
ArcMap session and open the attribute table. GWDiff is 
the difference in groundwater baseflow to each SFR2 
cell selected for comparison (equivalent to flux (“F”) as 
described in the “Understanding Streamflow Reporting” 
section), while SDiff is the difference in cumulative surface 
water flow of every SFR2 cell upgradient of and including 
the SFR2 cell selected for comparison (equivalent to “flow,” 
as described in “Understanding Streamflow Reporting”). 
Units of flow will be in cubic feet per day, the same as the 
SFR2 data originally exported from Groundwater Vistas.
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Our Mission
The Survey conducts earth-science 
surveys, field studies, and research. We 
provide objective scientif﻿ic information 
about the geology, mineral resources, 
water resources, soil, and biology 
of Wisconsin. We collect, interpret, 
disseminate, and archive natural 
resource information. We communicate 
the results of our activities through 
publications, technical talks, and 
responses to inquiries from the 
public. These activities support 
informed decision making by 
government, industry, business, and 
individual citizens of Wisconsin. 

This report is an interpretation of the 
data available at the time of preparation. 
Every reasonable ef﻿fort has been 
made to ensure that this interpretation 
conforms to sound scientific principles; 
however, the report should not be used 
to guide site-specif﻿ic decisions without 
verification. Proper use of the report 
is the sole responsibility of the user.

The use of company names in this 
document does not imply endorsement 
by the Wisconsin Geological and Natural 
History Survey.
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June 30, 1914, in cooperation with 
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opportunities in employment and 
programming, including Title VI, Title IX, 
and ADA requirements. If you need this 
information in an alternative format, 
contact the Office of Equal Oppor
tunity and Diversity Programs or the 
Wisconsin Geological and Natural 
History Survey (608.262.1705).
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